POJ 1256 Anagram

POJ 1256  Anagram
Time Limit: 1000 MS      Memory Limit: 10000 KB      64bit IO Format: %I64d & %I64u

Description

      You are to write a program that has to generate all possible words from a given set of letters. 
Example: Given the word "abc", your program should - by exploring all different combination of the three

 letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". 

In the word taken from the input file, some letters may appear more than once. For a given word,

 your program should not produce the same word

 more than once, and the words should be output in alphabetically ascending order. 


Input

          The input consists of several words. The first line contains a number giving the number of

words to follow.Each following line contains one word.

 A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters 

are to be considered different.The length of each word is less than 13.


Output

For each word in the input, the output should contain all different words that can be 

generated with the letters of the given word.

 The words generated from the same input word should be output in alphabetically ascending order.

 An upper case letter goes before the corresponding lower case letter.


Sample Input

3

aAb

abc

acba


Sample Output

Aab

Aba

aAb

abA

bAa

baA

abc

acb

bac

bca

cab

cba

aabc

aacb

abac

abca

acab

acba

baac

baca

bcaa

caab

caba

cbaa


Hint

An upper case letter goes before the corresponding lower case letter. 
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.


 本题主要是运用STL中的下一个排序函数(next_permutation())解答

由于需要对序列的大小进行重新的定义,所以用到了自己定义新的cmp()

函数进行调用对序列的大小顺序进行重新排。


附上代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;

int cmp(char a,char b)
{
	if(tolower(a) != tolower(b))
	return tolower(a) < tolower(b);
	else
	return a < b;
}

int main()
{
	int n;
	cin >> n;
	while(n--)
	{
		char s[20];
		cin >> s;
		sort(s,s+strlen(s),cmp);
		do
		{
			cout << s << endl;
		}while(next_permutation(s,s+strlen(s),cmp));
	}
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值