画8
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5352 Accepted Submission(s): 2296
Problem Description
谁画8画的好,画的快,今后就发的快,学业发达,事业发达,祝大家发,发,发.
Input
输入的第一行为一个整数N,表示后面有N组数据.
每组数据中有一个字符和一个整数,字符表示画笔,整数(>=5)表示高度.
每组数据中有一个字符和一个整数,字符表示画笔,整数(>=5)表示高度.
Output
画横线总是一个字符粗,竖线随着总高度每增长6而增加1个字符宽.当总高度从5增加到6时,其竖线宽度从1增长到2.下圈高度不小于上圈高度,但应尽量接近上圈高度,且下圈的内径呈正方形.
每画一个"8"应空一行,但最前和最后都无空行.
每画一个"8"应空一行,但最前和最后都无空行.
Sample Input
2 A 7 B 8
Sample Output
AA AA AA AA AA AA AA AA AA AA AA BBB BB BB BB BB BBB BB BB BB BB BB BB BBB
水题,找规律,我写的可能有点复杂
附上代码
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int t;
cin >> t;
getchar();
while(t--)
{
char str;
int n;
cin >> str >> n;
int t1 = n / 6 + 1; // 边的宽度
int t3 = (n - 3) / 2; // 上半部分的高度
int t4 = (n - 3) - t3; // 下半部分的高度
int t2 = t4; // 中间的宽度
for(int i = 0;i < t1 + t2;i++)
{
if(i < t1)
cout << " ";
else
cout << str;
}
cout << endl;
for(int j = 0;j < t3;j++)
{
for(int i = 0;i < 2 * t1 + t2;i++)
{
if(i < t1)
cout << str;
else if(i >= t1 && i < t1 + t2)
cout << " ";
else
cout << str;
}
cout << endl;
}
for(int i = 0;i < t1 + t2;i++)
{
if(i < t1)
cout << " ";
else
cout << str;
}
cout << endl;
for(int j = 0;j < t4;j++)
{
for(int i = 0;i < 2 * t1 + t2;i++)
{
if(i < t1)
cout << str;
else if(i >= t1 && i < t1 + t2)
cout << " ";
else
cout << str;
}
cout << endl;
}
for(int i = 0;i < t1 + t2;i++)
{
if(i < t1)
cout << " ";
else
cout << str;
}
cout << endl;
if(t > 0)
cout << endl;
}
return 0;
}