HDU 1086 You can Solve a Geometry Problem too (判断线段交叉,线段跨立)



You can Solve a Geometry Problem too
  Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u


Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :) 
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point. 

Note: 
You can assume that two segments would not intersect at more than one point. 
 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed. 
 

Output

For each case, print the number of intersections, and one line one case. 
 

Sample Input

    
    
2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
0.00 0.00 1.00 1.00
3
0.00 0.00 1.00 0.00
0.00 1.00 1.00 0.000
0
 

Sample Output

    
    
1
3
 

题目大意:

有 n 条直线,让你判断有多少个交点


分析:
判断两直线是否相交

分两步:
①:快速排斥
   设以线段P1P2为对角线的矩形为R,以线段Q1Q2为对角线的矩形为T,如果R和T不相交,显然两线段不会相交。
②:跨立
   如果两直线相交,则两直线必然相互跨立对方。若P1P2跨立Q1Q2,则矢量(P1-Q1)和(P2-Q1)位于矢量(Q2-Q1)的两侧,
  即(P1-Q1)X(Q2-Q1)*(P2-Q1)X(Q2-Q1)<0. 上式可改写为(P1-Q1)X(Q2-Q1)*(Q2-Q1)X(P2-Q1)>0. 
当(P1-Q1)X(Q2-Q1)=0 时,说明(P1-Q1)和(Q2-Q1)共线,但因为已经通过快速排斥实验,所以
  P1一定在线段Q1Q2上,同理,(Q2-Q1)X(P2-Q1)=0 说明P2一定在直线Q1Q2上。所以判断P1P2跨立Q1Q2的依据是:
(P1 - Q1) X (Q2 - Q1) * (Q2 - Q1) X (P2 -Q1)>=0        X 是叉乘的意思

附上一个判断线段交叉的解题思路:http://blog.csdn.net/xia842655187/article/details/51469130 点击打开链接


附上代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <vector>
#include <cmath>
#define LL long long
#define MAX_N 50000
using namespace std;

struct point
{
	double x,y;
};

struct Line
{
	point a,b;
};

int Seg(Line a,Line b)
{
    double k1=(a.a.x - b.a.x)*(b.b.y - b.b.x)-(a.b.x - b.b.x)*(b.a.y - b.a.x);
    double k2=(b.a.y - b.a.x)*(a.b.y - b.b.x)-(b.b.y - b.b.x)*(a.a.y - b.a.x);
    if(k1*k2>=0)
    	return 1;
    else
    	return 0;
}

int main()
{
	Line line[110];
	int n;
	while(cin >> n && n)
	{
		int ans = 0;
		for(int i = 0;i < n;i++)
		{
			scanf("%lf%lf%lf%lf",&line[i].a.x,&line[i].b.x,&line[i].a.y,&line[i].b.y);
			for(int j = 0;j < i;j++)
			{
				if(Seg(line[i],line[j]) && Seg(line[j],line[i]))
				ans++;
			}
		}
		cout << ans << endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值