08-图8 How Long Does It Take (25分)

08-图8 How Long Does It Take (25分).

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output “Impossible”.

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

#include<iostream>
#include<queue>
using namespace std;

#define MaxVertexNum 100
int InDegree[MaxVertexNum];
struct ENode {
	int V1,V2;
	int Weight;
};

typedef struct ENode* Edge;

struct AdjVNode {
	int AdjX;
	int weight;
	struct AdjVNode* Next;
};
typedef struct AdjVNode* PtrAdjVNode;

struct VNode {
	PtrAdjVNode FirstNode;
	int weight;
};

struct LNode {
	int Nv;
	int Ne;
	VNode V[MaxVertexNum];
};

typedef struct LNode *LGraph;

void InsertEdge(LGraph Graph,Edge E) {
	PtrAdjVNode NewNode=(PtrAdjVNode)malloc(sizeof(struct AdjVNode));
	NewNode->AdjX=E->V2;
	NewNode->weight=E->Weight;
	NewNode->Next=Graph->V[E->V1].FirstNode;
	Graph->V[E->V1].FirstNode=NewNode;

}

LGraph Create() {
	LGraph Graph=(LGraph)malloc(sizeof(struct LNode));
	cin>>Graph->Nv>>Graph->Ne;
	Edge E=(Edge)malloc(sizeof(struct ENode));
	for(int i=0; i<Graph->Nv; i++) {
		Graph->V[i].FirstNode=NULL;
		Graph->V[i].weight=0;
		InDegree[i]=0;
	}

	for(int i=0; i<Graph->Ne; i++) {
		cin>>E->V1>>E->V2>>E->Weight;
		InsertEdge(Graph,E);
	}
	return Graph;
}

void Prim(LGraph Graph) {

	int V,cnt=0,max=0;
	queue<int>Q;

	for(int i=0; i<Graph->Nv; i++) {
		for(PtrAdjVNode W=Graph->V[i].FirstNode; W; W=W->Next) {
			InDegree[W->AdjX]++;
		}
	}
	
	for(int i=0; i<Graph->Nv; i++) {
		if(InDegree[i]==0) {
			Q.push(i);
			cnt++;
		}
	}
	
	while(!Q.empty()) {
		V=Q.front();
		Q.pop();
		for(PtrAdjVNode W=Graph->V[V].FirstNode; W; W=W->Next) {
			InDegree[W->AdjX]--;
			if(Graph->V[W->AdjX].weight<Graph->V[V].weight+W->weight) {
				Graph->V[W->AdjX].weight=Graph->V[V].weight+W->weight;
			}
			if(InDegree[W->AdjX]==0) {
				Q.push(W->AdjX);
				cnt++;
			}
		}
	}
	if(cnt!=Graph->Nv) {
		printf("Impossible");
	} else {
		for(int i=0; i<Graph->Nv; i++) {
			if(Graph->V[i].weight>max) {
				max=Graph->V[i].weight;
			}
		}
		printf("%d",max);
	}
}
int main() {
	LGraph Graph=Create();
	Prim(Graph);
}
#include<bits/stdc++.h>
using namespace std;

struct Node {
	int data, weight;
	Node(int a, int b) {
		data = a;
		weight = b;
	}
};
int N, M, Indegree[105] = {0}, MinTime[105] = {0}, counts = 0;
vector<Node> vt[105];
bool visit[105] = {false};

int main() {
	cin >> N >> M;
	int v, u, w;
	for (int i = 0; i < M; i++) {
		cin >> v >> u >> w;
		Node temp = Node(u, w);
		vt[v].push_back(temp);
		Indegree[u]++;
	}
	queue<int> Qt;
	
	for (int i = 0; i < N; i++) {
		if (Indegree[i] == 0) {
			Qt.push(i);
			MinTime[i] = 0;
		}
	}
	
	while (!Qt.empty()) {
		int temp = Qt.front();
		Qt.pop();
		counts++;
		if (Qt.empty() && counts == N) cout << MinTime[temp];
		for (int i = 0; i < vt[temp].size(); i++) {
			int Vertex = vt[temp][i].data;
			Indegree[Vertex]--;
			if (Indegree[Vertex] == 0) Qt.push(Vertex);
			if (MinTime[Vertex] < MinTime[temp] + vt[temp][i].weight) {
				MinTime[Vertex] = MinTime[temp] + vt[temp][i].weight;
			} 
		}
	}
	if (counts != N) cout << "Impossible";
	
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值