POJ 2773 Happy 2006 容斥定理+二分

Happy 2006
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 12690 Accepted: 4472

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5
题意:现在给你一个m,那么从1开始与m互素的数字呈递增排列,求出第k个数字是多少?

思路:容斥+二分。二分答案找到什么时候是第k个数字即可,在一个区间【1,x】中与m互素的数字有多少个,这个不能用欧拉函数求(欧拉函数只能求【1,x】中与x互素的数字有多少个),用容斥定理就可以求出。先将m分解为素数,然后将这些素数组合的所有情况都表示出来,素数个数是奇数,就加上x/tmp,偶数就减去x/tmp;tmp为其中一些素数的最小公倍数(及乘积)。   简称奇加偶减。因为这些素数的所有组合都是确定不变的,所以直接先打个表预处理出来就行,变的是x,所以每次遍历一遍即可,不必每次都再求一次素数组合。

最后得到的答案还要判断一下,有可能还可以减小的。

AC代码:

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string>
#include<string.h>
#include<algorithm>
#define LL long long
#define N 1000000
using namespace std;
int f[10000],lf;
int a[N];
LL check(LL x)
{
    LL ans=0;
    int k=(1<<lf);
    for(int i=1; i<k; i++)
        ans+=x/a[i];
    return x-ans;
}
int main()
{
    LL n,k;
    while(~scanf("%I64d%I64d",&n,&k))
    {
        lf=0;
        for(int i=2; i*i<=n; i++)
        {
            if(n%i==0)
            {
                f[lf++]=i;
                while(n%i==0)
                    n/=i;
            }
        }
        if(n!=1) f[lf++]=n;
        int kk=(1<<lf);
        for(int i=1; i<kk; i++)
        {
            int flag=0;
            LL tmp=1;
            for(int j=0; j<lf; j++)
                if(i&(1<<j))
                {
                    tmp*=f[j];
                    flag++;
                }
            if(flag&1)  a[i]=tmp;
            else   a[i]=-tmp;
        }
        LL l=1LL,r=1LL<<62,mid,x;
        while(l<r)
        {
            mid=(l+r)>>1;
            x=check(mid);
            if(x>k) r=mid;
            else if(x<k) l=mid;
            else if(x==k)
            {
                l=mid;
                break;
            }
        }
        while(check(l)==k) l--;
        l++;
        printf("%I64d\n",l);
    }
}









  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值