poj2031——Building a Space Station【最小生成树】

Building a Space Station
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11514 Accepted: 5282

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 r1 
x2 y2 z2 r2 
... 
xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

题目链接:点击打开链接

这道题就是一道最小生成树模板题,其中还有一点小坑。题目的大致意思就是:在一片地方有一些小细胞,这些小细胞的坐标为x,y,z半径为r,并且这些细胞是可以重叠的。要把这些小球全部连接在一起问所需要最小需要多长的绳子。注意如果细胞是重叠的

就不需要用绳子连接了。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
int pre[10005];
struct node{
	double x,y,z,r;
}v[10005];
struct note{
	double q,p,s;
}e[10005];
void init(int n){
	int i;
	for(i=1;i<=n;i++){
		pre[i]=i;
	}
}
int find(int x){
	if(pre[x]==x) return x;
	else{
		pre[x]=find(pre[x]);
		return pre[x];
	}
}
int join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy){
		pre[fx]=fy;
		return 1;
	}
	return 0;
}
double dist(double x1,double y1,double z1,double x2,double y2,double z2){
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)+(z1-z2)*(z1-z2));
}
bool cmp1(note a,note b){
	return a.s<b.s;
}
int main(){
	int n;
	while(~scanf("%d",&n)&&n){
		init(n);
		int i,j,k;
		for(i=1;i<=n;i++){
			scanf("%lf %lf %lf %lf",&v[i].x,&v[i].y,&v[i].z,&v[i].r);
		}
		k=0;
		for(i=1;i<=n;i++){
			for(j=i+1;j<=n;j++){
				e[k].p=i;
				e[k].q=j;
				if(dist(v[i].x,v[i].y,v[i].z,v[j].x,v[j].y,v[j].z)<=(v[i].r+v[j].r)){
					e[k++].s=0.000;//判断细胞是否重叠
				}
				else{
					e[k++].s=dist(v[i].x,v[i].y,v[i].z,v[j].x,v[j].y,v[j].z)-v[i].r-v[j].r;
				}
			}
		}
		sort(e,e+k,cmp1);
		int cnt;
		cnt=0;
		double sum;
		sum=0;
		for(j=0;j<k;j++){
			if(join(e[j].p,e[j].q)){
				sum=sum+e[j].s;
				cnt++;
			}
			if(cnt==n-1) break;
		}
		printf("%.3lf\n",sum);
	}
	return 0;
}

这道题的解法和杭电的畅通工程再续那道题解法相同,题目链接点击打开链接

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 10005
using namespace std;
struct node{
	int x,y;
}cost[N];
struct note{
	int a,b;
	double v;
}edge[N];
double dist(int x1,int x2,int y1,int y2){
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
double cmp1(note x,note y){
	return x.v<y.v;
}
int pre[N];
void init(int n){
	for(int i=1;i<=n;i++){
		pre[i]=i;
	}
}
int find(int x){
	if(pre[x]==x) return x;
	else{
		pre[x]=find(pre[x]);
		return pre[x];
	}
}
int join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy){
		pre[fy]=fx;
		return 1;
	}
	return 0;
}
int main(){
	int t,c;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&c);
		init(c);
		for(int i=1;i<=c;i++){
			scanf("%d %d",&cost[i].x,&cost[i].y);
		}
		int ans=0;
		for(int i=1;i<=c;i++){
			for(int j=i+1;j<=c;j++){
				edge[ans].a=i;
				edge[ans].b=j;
				edge[ans++].v=dist(cost[i].x,cost[j].x,cost[i].y,cost[j].y);
			}
		}
		sort(edge,edge+ans,cmp1);
		int cnt=0;
		double sum=0;
		bool flag=false;
		for(int i=0;i<ans;i++){
			if(edge[i].v>=10&&edge[i].v<=1000){
				if(join(edge[i].a,edge[i].b)){
					sum=sum+edge[i].v;
				}
			}
			else continue;	
		}
		for(int i=1;i<=c;i++){
			if(pre[i]==i) cnt++;//判断集合的个数 
			if(cnt>1){
				flag=true;//cnt>1就说明还有小岛没连在一起 
				break;
			}
		}
		if(flag) printf("oh!\n");
		else printf("%.1lf\n",sum*100);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值