Building a Space Station
题目描述:
You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.
All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor’, or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.
You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.
You can ignore the width of a corridor. A corridor is built between points on two cells’ surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.
The input consists of multiple data sets. Each data set is given in the following format.
Input
n
x1 y1 z1 r1
x2 y2 z2 r2
…
xn yn zn rn
The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.
The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.
Each of x, y, z and r is positive and is less than 100.0.
The end of the input is indicated by a line containing a zero.
Output
For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.
Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.
Sample Input
3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0
Sample Output
20.000
0.000
73.834
题意:有n个圆形区域,给出每个圆的圆心坐标及半径,求这n个圆相互连通的最短距离是多少。
题解:两个圆可能会出现相交、相切甚至重合的情况,出现这些情况的圆是已经连通的,我们只需要找两圆圆心距离大于半径之和的圆进行连通,剩下的就是构造最小生成树。
注意G++编译器输出要用%f,不然会WA
AC代码:
#include <iostream>
#include <algorithm>
#include <math.h>
#include <cstdio>
#include <cmath>
#include <stdlib.h>
using namespace std;
int n,id,pre[105];
struct node
{
int from,to;
double w;
} e[12000];
struct st
{
double x,y,z,r;
} s[105];
bool cmp(node a,node b)
{
return a.w<b.w;
}
int Find(int x)
{
if(x==pre[x])
return x;
else
return pre[x]=Find(pre[x]);
}
double Kruskal()
{
sort(e,e+id,cmp);
double sum=0,cnt=0;
for(int i=0; i<id; i++)
{
int u=e[i].from,v=e[i].to;
double w=e[i].w;
int fu=Find(u),fv=Find(v);
if(fu==fv)
continue;
else
{
sum+=w;
cnt++;
pre[fu]=fv;
}
}
return sum;
}
int main()
{
while(scanf("%d",&n),n!=0)
{
id=0;
for(int i=1; i<=n; i++)
pre[i]=i;
for(int i=1; i<=n; i++)
{
double x,y,z,r;
scanf("%lf%lf%lf%lf",&x,&y,&z,&r);
s[i]= {x,y,z,r};
}
for(int i=1; i<=n; i++)
{
for(int j=i+1; j<=n; j++)
{
double x1=s[i].x,y1=s[i].y,z1=s[i].z,r1=s[i].r;
double x2=s[j].x,y2=s[j].y,z2=s[j].z,r2=s[j].r;
double dis=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)+(z1-z2)*(z1-z2));
if(dis>r1+r2) //将满足条件的边存入;
e[id++]= {i,j,dis-(r1+r2)};
else //不满足条件代表已连通;
{
int fx=Find(i),fy=Find(j); //将已连通的点加入到最小生成树中;
if(fx!=fy)
pre[fx]=fy;
}
}
}
double ans=Kruskal();
printf("%.3f\n",ans); //G++编译器输出用%f;
}
return 0;
}