poj1127——Jack Straws【计算几何,点和向量之间的关系】

Jack Straws

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5342 Accepted: 2422

Description

In the game of Jack Straws, a number of plastic or wooden "straws" are dumped on the table and players try to remove them one-by-one without disturbing the other straws. Here, we are only concerned with if various pairs of straws are connected by a path of touching straws. You will be given a list of the endpoints for some straws (as if they were dumped on a large piece of graph paper) and then will be asked if various pairs of straws are connected. Note that touching is connecting, but also two straws can be connected indirectly via other connected straws.

Input

Input consist multiple case,each case consists of multiple lines. The first line will be an integer n (1 < n < 13) giving the number of straws on the table. Each of the next n lines contain 4 positive integers,x1,y1,x2 and y2, giving the coordinates, (x1,y1),(x2,y2) of the endpoints of a single straw. All coordinates will be less than 100. (Note that the straws will be of varying lengths.) The first straw entered will be known as straw #1, the second as straw #2, and so on. The remaining lines of the current case(except for the final line) will each contain two positive integers, a and b, both between 1 and n, inclusive. You are to determine if straw a can be connected to straw b. When a = 0 = b, the current case is terminated. 

When n=0,the input is terminated. 

There will be no illegal input and there are no zero-length straws. 

Output

You should generate a line of output for each line containing a pair a and b, except the final line where a = 0 = b. The line should say simply "CONNECTED", if straw a is connected to straw b, or "NOT CONNECTED", if straw a is not connected to straw b. For our purposes, a straw is considered connected to itself.

Sample Input

7
1 6 3 3 
4 6 4 9 
4 5 6 7 
1 4 3 5 
3 5 5 5 
5 2 6 3 
5 4 7 2 
1 4 
1 6 
3 3 
6 7 
2 3 
1 3 
0 0

2
0 2 0 0
0 0 0 1
1 1
2 2
1 2
0 0

0

Sample Output

CONNECTED 
NOT CONNECTED 
CONNECTED 
CONNECTED 
NOT CONNECTED 
CONNECTED
CONNECTED
CONNECTED
CONNECTED

Source

East Central North America 1994

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator

先构造向量结构体,在判断点和向量之间的关系,在用一个关联矩阵储存每一个点之间的关系,最后用floyd算法求一下传递闭包。

#include<algorithm>
#include<cstdio>
#include<cmath>
#include<iostream>
#include<cstring>
using namespace std;
const int MAX_N=1005;
double EPS=1e-10;
//考虑误差的加法计算
double add(double a,double b){
    if(abs(a+b)<EPS*(abs(a)+abs(b))) return 0;
    return a+b;
}
//二维向量结构体
struct P{
    double x,y;
    P() {};
    P(double x,double y) :x(x),y(y){
    }
    P operator + (P p){
        return P(add(x,p.x),add(y,p.y));
    }
    P operator - (P p){
        return P(add(x,-p.x),add(y,-p.y));
    }
    P operator * (double d){
        return P(x*d,y*d);
    }
    double dot(P p){  //内积
        return add(x*p.x,y*p.y);
    }
    double det(P p){  //外积
        return add(x*p.y,-y*p.x);//如果里面有对应的结构体类型所使用的运算符为自己定义的运算符
    }

};
//判断点q是否在线段p1-p2上
bool on_seg(P p1,P p2,P q){
    return (p1-q).det(p2-q)==0&&(p1-q).dot(p2-q)<=0;
}
//计算直线p1-p2与直线q1-q2的交点
P intersection(P p1,P p2,P q1, P q2){
    return p1+(p2-p1)*((q2-q1).det(q1-p1)/(q2-q1).det(p2-p1));
}
int n;
P p[MAX_N],q[MAX_N];
int a[MAX_N],b[MAX_N];
bool g[MAX_N][MAX_N];   //构造关系相连图
int main(){
    int n;
    while(~scanf("%d",&n)&&n){
        int m=0;
        memset(g,0,sizeof(g));
        for(int i=0;i<n;i++){
            scanf("%lf%lf%lf%lf",&p[i].x,&p[i].y,&q[i].x,&q[i].y);
        }
        int t1,t2;
        while(~scanf("%d%d",&t1,&t2)&&t1,t2){
            a[m]=t1;
            b[m]=t2;
            m++;
        }
        for(int i=0;i<n;i++){
            g[i][i]=true;
            for(int j=0;j<i;j++){
                //判断木棍i和木棍j是否有公共点
                if((p[i]-q[i]).det(p[j]-q[j])==0){//向量p1*向量p2
                    //平行时
                    g[i][j]=g[j][i]=on_seg(p[i],q[i],p[j])
                                    ||on_seg(p[i],q[i],q[j])
                                    ||on_seg(p[j],q[j],p[i])
                                    ||on_seg(p[j],q[j],q[i]);
                }
                else{
                    //非平行时
                    P r=intersection(p[i],q[i],p[j],q[j]);
                    g[i][j]=g[j][i]=on_seg(p[i],q[i],r)&&on_seg(p[j],q[j],r);
                }
            }
            //通过floyd_warshall算法判断任意两点间是否相连
            for(int k=0;k<n;k++){
                for(int i=0;i<n;i++){
                    for(int j=0;j<n;j++){
                        g[i][j]|=g[i][k]&&g[k][j];
                    }
                }
            }
        }
        for(int i=0;i<m;i++){
            puts(g[a[i]-1][b[i]-1]?"CONNECTED":"NOT CONNECTED");
        }

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值