HDU1010——Tempter of the Bone【DFS,奇偶剪枝,路径剪枝】

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 146756    Accepted Submission(s): 39139


 

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 

 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

 

 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

 

 

Sample Input

 

4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

 

 

Sample Output

 

NO YES

 

 

Author

ZHANG, Zheng

 

 

Source

ZJCPC2004

 

 

Recommend

JGShining

 

 

Statistic | Submit | Discuss | Note

题目大意:从s点出发到达D点,问能不能恰好在T秒内到达。

这道题看似是DFS板子题,但同时要注意奇偶剪枝,否则会超时,关于奇偶剪枝可以参考一下這篇博客:https://blog.csdn.net/chyshnu/article/details/6171758

同时可以借助这道题仔细了解一下DFS中的回溯过程。

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;
int n,m,t;
int sx,sy,ex,ey;
bool flag;
char mp[10][10];
bool vis[10][10];
int dx[4]={1,0,-1,0},dy[4]={0,-1,0,1};
void DFS(int x,int y,int ans){
    vis[x][y]=1;
    if(mp[x][y]=='D'&&ans==t){
        flag=1;
        return ;
    }
    if(ans>t) return;
    //奇偶剪枝
    int temp=t-ans-abs(ex-x)-abs(ey-y);//当前点到终点的距离
    if((temp&1)||temp<0) return ;
    for(int i=0;i<4;i++){
        int nx=x+dx[i];
        int ny=y+dy[i];
        if(nx>=0&&nx<n&&ny>=0&&ny<m&&!vis[nx][ny]&&mp[nx][ny]!='X'){
            //printf("(%d,%d)---\n",nx,ny);
            DFS(nx,ny,ans+1);
            if(flag) return ;
            vis[nx][ny]=0;//回溯
        }
    }
}
int main(){
    while(~scanf("%d%d%d",&n,&m,&t)&&n,m,t){
        memset(vis,0,sizeof(vis));
        flag=0;
        int sum=0;
        for(int i=0;i<n;i++) scanf("%s",mp[i]);
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(mp[i][j]=='S'){ sx=i;sy=j;}
                if(mp[i][j]=='D'){ ex=i;ey=j;}
                if(mp[i][j]=='X') sum++;
            }
        }
        //路径剪枝
        if((n*m-sum)>=t){
            DFS(sx,sy,0);
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值