Tempter of the Bone (dfs + 奇偶剪枝)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1591 Accepted Submission(s): 528
 
Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

\\\\\\\'X\\\\\\\': a block of wall, which the doggie cannot enter; 
\\\\\\\'S\\\\\\\': the start point of the doggie; 
\\\\\\\'D\\\\\\\': the Door; or
\\\\\\\'.\\\\\\\': an empty block.

The input is terminated with three 0\\\\\\\'s. This test case is not to be processed.
 
Output

            For each test case, print in one line \\\\\\\"YES\\\\\\\" if the doggie can survive, or \\\\\\\"NO\\\\\\\" otherwise.
 
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
 
Sample Output
NO
YES
 
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string.h>
using namespace std;
/*
    01010101
    10101010
    01010101
    10101010
0代表偶数步,1代表奇数步,自己画个图,再结合上图,一个点到另一个点,最短是奇数步,怎么走都是奇数步。
 偶数步同理
 
 设 temp = t - s1 - s2;
 其中t-cnt味剩余的步数或者说时间,另其为T
 
 s1+s2为剩余步数,另其为S
 
 如果走偶数步要求的时间是奇数,或者走奇数步要求的时间是偶数,都明显不可行
 
 而轻易得出奇数-偶数 = 奇数,反之亦然
 
 而奇数-奇数= 偶数,偶数-偶数=偶数
 
 搜易tem必须为偶
 */
char mmap[15][15];
int dir[4][2] = {{-1, 0}, {0, 1}, {1, 0}, {0, -1}};
int n, m, t, end_x, end_y, flag;

void dfs(int x, int y, int cnt) {
    if (x > n || x <= 0 || y > m || y <= 0)
        return ;
    if (x == end_x && y == end_y && cnt == t)
        flag = 1;
    if (flag)
        return;
    int s1 = fabs(x - end_x);
    int s2 = fabs(y - end_y);
    int temp = t - s1 - s2 - cnt;
    
    if (temp < 0 || temp&1)
        return;
    
    for (int i = 0; i < 4; ++i) {
        if (mmap[x + dir[i][0]][y + dir[i][1]] != 'X') {
            mmap[x + dir[i][0]][y + dir[i][1]] = 'X';
            
            dfs(x + dir[i][0], y + dir[i][1], cnt+1);
            
            mmap[x + dir[i][0]][y + dir[i][1]] = '.';
        }
    }
    return ;
}

int main() {
    int wall;
    int start_x, start_y;
    while (cin >> n >> m >> t && n + m + t) {
        wall = 0;
        memset(mmap, 0, sizeof(mmap));
        for (int i = 1; i <= n; ++i){
            for (int j = 1; j <= m; ++j) {
                cin >> mmap[i][j];
                if (mmap[i][j] == 'X')
                    wall++;
                else if (mmap[i][j] == 'S')
                    start_x = i, start_y = j;
                else if (mmap[i][j] == 'D')
                    end_x = i, end_y = j;
            }
        }
        if (n*m - wall <= t) {
            cout << "NO\n";
            continue;//忘了写continue了
        }
        flag = 0;
        mmap[start_x][start_y] = 'X';//一直忘了把初始点给删掉;
        dfs(start_x, start_y, 0);
        
        if (flag) {
            cout << "YES\n";
        } else
            cout << "NO\n";
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值