POJ3984——迷宫问题【BFS,记录路径】

迷宫问题

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33319 Accepted: 18985

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目思路:用BFS求最短路径,同时用一个数组记录当前节点的前一个点的坐标。因为数组记录的是反响的坐标,所以1最后要递归输出。

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
int maze[6][6];
bool vis[6][6];
struct node{
    int x,y,step;
    bool friend operator <(node a,node b){
        return a.step>b.step;
    }
};
node path[100][100];
int dx[4]={1,0,-1,0},dy[4]={0,-1,0,1};
void BFS(){
    priority_queue<node> qu;
    node e1;
    e1.x=0,e1.y=0,e1.step=0;
    qu.push(e1);
    vis[e1.x][e1.y]=1;
    int ans=0;
    while(!qu.empty()){
        e1=qu.top();qu.pop();
        node e2;
        if(e1.x==4&&e1.y==4){
            ans=e1.step;
            break;
        }
        for(int i=0;i<4;i++){
            e2.x=e1.x+dx[i];
            e2.y=e1.y+dy[i];
            if(e2.x>=0&&e2.x<5&&e2.y>=0&&e2.y<5&&!vis[e2.x][e2.y]&&maze[e2.x][e2.y]!=1){
                e2.step=e1.step+1;
                vis[e2.x][e2.y]=1;
                qu.push(e2);
                path[e2.x][e2.y].x=e1.x;
                path[e2.x][e2.y].y=e1.y;//记录当前节点的上一步;
            }
        }
    }
}
void print(int x,int y){
    if(x==0&&y==0){
        printf("(0, 0)\n");
        return ;
    }
    print(path[x][y].x,path[x][y].y);
    printf("(%d, %d)\n",x,y);
}
int main(){
    for(int i=0;i<5;i++){
        for(int j=0;j<5;j++){
            scanf("%d",&maze[i][j]);
        }
    }
    memset(vis,0,sizeof(vis));
    BFS();
    print(4,4);
    //printf("(4, 4)\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值