HDU2647——Reward【拓扑排序】

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12986    Accepted Submission(s): 4143


 

Problem Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

 

 

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

 

 

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

 

 

Sample Input

 

2 1 1 2 2 2 1 2 2 1

 

 

Sample Output

 

1777 -1

 

 

Author

dandelion

 

 

Source

曾是惊鸿照影来

 

 

Recommend

yifenfei   |   We have carefully selected several similar problems for you:  1285 3342 1811 2680 2112 

 

 

Statistic | Submit | Discuss | Note

Home | TopHangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2018 HDU ACM Team. All Rights Reserved.
Designer & Developer : Wang Rongtao LinLe GaoJie GanLu
Total 0.000000(s) query 5, Server time : 2018-08-04 23:11:50, Gzip enabled

 

题目大意:要发工资了,每一个员工都要不同的要求,每一个员工都要比自己认为的后面的那一位拿的多,并且基本工资为888元,问老板最少发多少工资。

思路:用链式前向星反向构图,在用一个数组记录每一个人的工资,把入度为0的点的工资为888元,在他们后面的依次多一元,然后逐渐叠加。

#include<algorithm>
#include<cstring>
#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
using namespace std;
const int MAXN=100010;
int n,m,top,cnt;
int head[MAXN];
int a[MAXN],deg[MAXN];
long long ans[MAXN];//ans用来记录每一个人的钱数
struct node{
    int to,next;
}edge[MAXN*2];
void addEdge(int u,int v){
    edge[++top].to=v;
    edge[top].next=head[u];
    head[u]=top;
    deg[v]++;
}
void topsort(){
    queue<int> qu;
    for(int i=1;i<=n;i++){
        if(deg[i]==0){
            qu.push(i);
            ans[i]=888;
        }
    }
    while(!qu.empty()){
        int x=qu.front();qu.pop();
        a[++cnt]=x;
        for(int i=head[x];i!=-1;i=edge[i].next){
            int y=edge[i].to;
            if(--deg[y]==0){
                qu.push(y);
                ans[y]=ans[x]+1;
            }
        }
    }
}
int main(){
    while(~scanf("%d%d",&n,&m)){
        int a,b;
        memset(head,-1,sizeof(head));
        memset(ans,0,sizeof(ans));
        memset(deg,0,sizeof(deg));
        cnt=0,top=0;
        for(int i=1;i<=m;i++){
            scanf("%d %d",&a,&b);
            addEdge(b,a);
        }
        topsort();
        long long sum=0;
        for(int i=1;i<=n;i++){
            sum=sum+ans[i];
        }
        if(cnt==n) printf("%lld\n",sum);
        else printf("-1\n");

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值