HDU1260——Tickets【动态规划】

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7775    Accepted Submission(s): 3952


 

Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

 

 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

 

 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

 

 

Sample Input

 

2 2 20 25 40 1 8

 

 

Sample Output

 

08:00:40 am 08:00:08 am

 

 

Source

浙江工业大学第四届大学生程序设计竞赛

 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1257 1160 1231 1074 1069 

 

题目大意:一个人在买电影票,他可以两个人买一张也可以一个人买一张,并且买一张票所花费的时间不同,问他最早可以什么时候回家。

思路:dp[i]表示买i张电影票所需要的最少时间,状态转移方程为:dp[i]=min{dp[i-1]+a[i],dp[i-2]+b[i]}。a[i[为买一张单人票所需的时间,b[i]为买一张双人票所需的时间。

#include<algorithm>
#include<cstring>
#include<cstdio>
#include<iostream>
using namespace std;
const int MAXN=1000010;
int dp[MAXN],a[MAXN],b[MAXN];//dp表示卖出前i张票所需最小时间
int main(){
    int n,k;
    cin>>n;
    while(n--){
        cin>>k;
        for(int i=1;i<=k;i++){
            cin>>a[i];
            //dp[i]=a[i];//先初始化dp数组
        }
        for(int i=2;i<=k;i++) cin>>b[i];
        dp[1]=a[1];//卖出前一张牌要用的时间
        dp[2]=min(a[1]+a[2],b[2]);//卖出前两张牌要用的时间
        for(int i=3;i<=k;i++){
            dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
        }
        int hour=8+dp[k]/3600;
        int minute=dp[k]%3600/60;
        int second=dp[k]%3600%60;
        printf("%02d:%02d:%02d am\n",hour,minute,second);
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值