J - Longest Ordered Subsequence

J - Longest Ordered Subsequence
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
解析:这题可以用DP做。
基本思路:开两个数组dp[1005] x[1005],DP用来存子序列的长度,X用来存数据。首先对DP赋初值为1。输入一个数X[i]让
它与前边的几个数下X[j]相比较,如果x[i]>x[j],则dp[i]=dp[j]+1。注意条件dp[i]<=dp[j],和下面代码一起看可能
更好理解。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int dp[1005],x[1005];
int main()
{
    int n;
    scanf("%d",&n);
    int j;
    for(int i=0; i<n; i++)
    {
        dp[i]=1;
        scanf("%d",&x[i]);
        for( j=0; j<i; j++)
            if(x[i]>x[j]&&dp[i]<=dp[j])
                dp[i]=dp[j]+1;

    }
    int a=0;
    for(int i=0; i<n; i++)
        if(a<dp[i])
            a=dp[i];
    printf("%d\n",a);
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值