BUYING FEED

BUYING FEED

时间限制:3000 ms  |  内存限制:65535 KB
难度:4
描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit.  What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution. Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:     
0   1   2  3   4   5    
---------------------------------         
1       1   1                Available pounds of feed         
1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
12 5 3 
3 1 2
4 1 2
1 1 1
样例输出
7
题解:考察贪心思想,重点就是思维的转变,如果对题上的单价不加改变,这道题很难做,但只要稍加改变每个商店的每斤饲料的单价,就变为了简单的贪心题。把单价改成这个人在每个商店买1磅到达E点时的花费,把它作为这个商店的单价,那么我们在买时就不用考虑这个商店与E点的距离,只需要贪心选择单价小的即可。
#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
struct node
{
    int loca;
    int f;
    int a,a1;
}x[102];
bool cmp(node g,node h)
{
    return g.a1<h.a1;
}
int main()
{
    int t,k,e,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&k,&e,&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&x[i].loca,&x[i].f,&x[i].a);
            x[i].a1=x[i].a+e-x[i].loca;
        }
        sort(x,x+n,cmp);
        int s=0;
        for(int i=0;i<n;i++)
        {
           if(k>=x[i].f)
           {
               k-=x[i].f;
             s+=x[i].a1*x[i].f;
           }
           else
           {
               s+=k*x[i].a1;
               break;
           }

        }
        printf("%d\n",s);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值