三维树状数组-------

例题:

Problem E

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 12
Problem Description

Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N).
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].


 

Input

Multi-cases. First line contains N and M, M lines follow indicating the operation below. Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation. If X is 1, following x1, y1, z1, x2, y2, z2. If X is 0, following x, y, z.


 

Output

For each query output A[x, y, z] in one line. (1<=n<=100  sum of m <=10000)


 

Sample Input
  
  
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2


 

Sample Output
  
  
1 0 1

代码如下:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 102
using namespace std;
int c[M][M][M];
int lowbit(int x)
{
    return x&(-x);
}


void add(int x,int y,int z,int v)
{ for(int k=z;k<=101;k+=lowbit(k))
    for(int i=x;i<=101;i+=lowbit(i))
    {
        for(int j=y;j<=101;j+=lowbit(j))
        c[k][i][j]+=v;

    }
}

long long sum(int x,int y,int z)
{
    long long su=0;
    for(int k=z;k>0;k-=lowbit(k))
    for(int i=x;i>0;i-=lowbit(i))
    {
        for(int j=y;j>0;j-=lowbit(j))
        su+=c[k][i][j];

    }
    return su;
}

int main()
{
    int t,k;
    int x,y,z,x1,y1,z1;
    int m;
    while(~scanf("%d%d",&t,&m))
    {
        memset(c,0,sizeof(c));
        for(int i=1;i<=m;i++)
    {
        cin>>k;
        if(k==1)
        {
            cin>>x>>y>>z>>x1>>y1>>z1;
            add(x,y,z,1);
            add(x1+1,y1+1,z1+1,-1);
            add(x,y,z1+1,-1);
            add(x1+1,y,z,-1);
            add(x,y1+1,z,-1);
            add(x1+1,y,z1+1,1);

            add(x,y1+1,z1+1,1);
            add(x1+1,y1+1,z,1);
        }
        else if(k==0)
        {
            cin>>x>>y>>z;
            cout<<sum(x,y,z)%2<<endl;
        }
    }
    }
    return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值