Balancing act树形dp(求树的重心)

Balancing Act
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10726 Accepted: 4463

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2


这道题大概是很经典的一道题目了。以前整理过,再整理一遍。就是树的重心的含义也就是有一个点,他的所有子树中最大的一个子树就整棵树而言是最小的。毫无疑问要用树形dp。

下面记录一下各个数组的含义:

num[i]:表示以i为节点的往下的子树的个数

dp[i]:表示以i为节点的所有子树中个数最大的一个(包括连接father的那一块)

方法:

①:下方子树节点数可以在dfs过程中求出;

②:上方子树=总结点数N-(下方子树节点总数num【】+1)

具体见代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 20000+100
#define MAXM 40000+1000
using namespace std;
struct Edge
{
    int from, to, next;
};
Edge edge[MAXM];
int head[MAXN], edgenum;
int dp[MAXN];//存储以该节点为根节点的所有子树中 最大的节点数
int num[MAXN];//存储以该节点为根节点的下方树的节点数
int N;
void init()
{
    edgenum = 0;
    memset(head, -1, sizeof(head));
}
void addEdge(int u, int v)
{
    Edge E = {u, v, head[u]};
    edge[edgenum] = E;
    head[u] = edgenum++;
}
void getMap()
{
    int a, b;
    for(int i = 1; i < N; i++)
    {
        scanf("%d%d", &a, &b);
        addEdge(a, b);
        addEdge(b, a);
    }
}
void dfs(int u, int fa)
{
    num[u] = 1, dp[u] = 0;
    for(int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].to;
        if(v == fa) continue;//不能再回来找它的父节点
        dfs(v, u);//求出以v为根节点的子树的节点数
        dp[u] = max(dp[u], num[v]);//更新下方子树
        num[u] += num[v];//累加到当前节点 为了求上方子树节点数
    }
    dp[u] = max(dp[u], N - num[u]);//更新上方子树
}
void solve()
{
    dfs(1, -1);
    int ans = N;
    int node = 1;
    for(int i = 1; i <= N; i++)
    {
        if(ans > dp[i])
            ans = dp[i], node = i;
    }
    printf("%d %d\n", node, ans);
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &N);
        init();
        getMap();
        solve();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值