Balancing Act (树形dp 求树的重心板题)

题目:Balancing Act 

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.

For example, consider the tree:


Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.
Input
The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.
Output
For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.
Sample Input
1
7
2 6
1 2
1 4
4 5
3 7
3 1
Sample Output

1 2


题意:给出一棵树,找出重心。

树的重心:与该节点相连的所有子树中,(该)节点数最多的子树的节点数 是 所有节点的节点数最多的子树的最小值。

(有点绕但是还是比较好理解的……)

输入:

第一个数是样例的组数,接下来的n是有n个节点,接下来的n-1行每一行给出两个节点,表示这两个节点相连接。

输出:

输出重心是哪一点,然后输出该点的最大子树的节点数。

思路:

用vector建树,visit作为标记数组,dp[i]表示以i为balance得到的最大子集个数,dp1[i]数组表示(包含这个节点)其所有子节点的个数。

状态转移方程:

dp1[now] += dp1[son];

dp[now] = max(dp[now],dp1[son]);

这个题也可以用二维数组做,这里不写代码了。二维数组就是dp[i][0]表示dp[i],dp[i][1] 表示dp1[i]

状态转移方程:

dp[now][1] += dp[son][1];

dp[now][0] = max(dp[now][0],dp[son][1])

源代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
#include <cmath>
#include <vector>
#define maxn 1000000
typedef long long ll;
using namespace std;
int dp[maxn];
int dp1[maxn];
int visit[maxn];
int v[maxn];
vector <int> tree[maxn];
int n;
void tree_dp(int now){
    if (visit[now])
        return ;
    visit[now] = 1;
    for (int i = 0; i < tree[now].size(); i++){
        if (tree[now][i] != now && !visit[tree[now][i]]){
            tree_dp(tree[now][i]);
            dp1[now] += dp1[tree[now][i]];
            dp[now] = max(dp[now],dp1[tree[now][i]]);
        }
    }
    dp1[now] += 1;
    dp[now] = max(dp[now],n-dp1[now]);//总点数减去该点的所有子节点表示父节点的子树
}
int main(){
    int N;
    while (scanf("%d",&N)!=EOF){
        while (N--){
        scanf("%d",&n);
        memset(visit,0,sizeof(visit));
        memset(dp,0,sizeof(dp));
        memset(dp1,0,sizeof(dp));
        memset(v,0,sizeof(v));
        for (int i = 0; i <= n; i++)
            tree[i].clear();
        int start,end;
        for (int i = 0; i < n-1; i++){
            scanf("%d%d",&start,&end);
            tree[start].push_back(end);
            tree[end].push_back(start);
        }
        tree_dp(1);
        int minn = dp[1];
        int id = 1;
        for (int i = 1; i <= n; i++){
            if (minn > dp[i]){
                minn = dp[i];
                id = i;
            }
        }
        printf("%d %d\n",id,minn);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值