hdu5883【欧拉路】 每个点都有权值,要求按照欧拉路或者通路走一遍使得权值异或值最大

该博客探讨了一种特殊的欧拉路径问题,其中每个节点具有权值,目标是找出一条路径,使路径上所有节点的权值异或得到最大值。如果无法形成欧拉路径,则输出'Impossible'。解决策略包括判断是否存在欧拉回路或欧拉通路,并据此进行相应的异或操作。文章提到了可能的错误点,如正确计算异或操作的次数,并附有代码示例。
摘要由CSDN通过智能技术生成
The Best Path
Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1846    Accepted Submission(s): 756
Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,...,an) for each lake. If the path she finds is P0→P1→...→Pt, the lucky number of this trip would be aP0XORaP1XOR...XORaPt. She want to make this number as large as possible. Can you help her?
Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
For each test case, in the first line there are two positive integers N (N≤100000) and M (M≤500000), as described above. The i-th line of the next N lines contains an integer ai(∀i,0≤ai≤10000) representing the number of the i-th lake.
The i-th line of the next M lines contains two integers ui and vi representing the i-th river between the ui-th lake and vi-th lake. It is possible that ui=vi.
Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".
Sample Input
2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4
Sample Output
2
Impossible
Source
 2016 ACM/ICPC Asia Regional Qingdao Online  
Recommend

wange2014

题目大意:就是每条路都只走一边,问经过的点的最大权值是多少。如果没有这种情况输出“Impossible”

思路:首先要找是否满足欧拉回路或者欧拉通路。(方法,求出每个点的度。如果奇数度是0个,那么是欧拉回路,如果奇数度是2个,那么是欧拉通路。否则什么都不是)然后如果是欧拉通路的话每个点都要根据度的不同进行异或操作;如果是欧拉回路的话,一次枚举起点即可。易错点在于进行抑或时一定要注意次数,是否亦或

具体flag==2时的解释见下图:


代码1:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
const int maxm=500050;
int d[maxn];
int num[maxn];
int t,n,m;
int main()
{
    int flag;
    int u,v;
    scanf("%d",&t);
    while(t--)
    {
        flag=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
        }
        memset(d,0,sizeof(d));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&u,&v);
            d[u]++;
            d[v]++;
        }
        int lala=0;
        for(int i=1;i<=n;i++)
        {
            if(d[i]%2==1)
                lala++;
        }
        if(lala==0)//欧拉回路
        {
            flag=1;
        }
        else if(lala==2)//欧拉通路
        {
            flag=2;
        }
        else
        {
            flag=0;
        }
        //cout<<flag<<"flag"<<endl;
        if(flag==0)
        {
            puts("Impossible");
            continue;
        }
       int ans=0;
       if(flag==1)
       {
           for(int i=1;i<=n;i++)
           {
               if(d[i]/2%2==1)
                ans^=num[i];
           }
           ans^=num[1];
           for(int i=2;i<=n;i++)
           {
               ans=max(ans,ans^num[i]);
           }
       }
       else if(flag==2)
       {
        for(int i=1;i<=n;i++)
        {
            if(d[i]%2==0)
            {
                if((d[i]/2)%2==1)
                    ans^=num[i];
            }
            else
            {
                if((d[i]/2+1)%2==1)
                ans^=num[i];
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

代码2:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
const int maxm=500050;
int d[maxn];
int num[maxn];
int t,n,m;
int main()
{
    int flag;
    int u,v;
    scanf("%d",&t);
    while(t--)
    {
        flag=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
        }
        memset(d,0,sizeof(d));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&u,&v);
            d[u]++;
            d[v]++;
        }
        int lala=0;
        for(int i=1;i<=n;i++)
        {
            if(d[i]%2==1)
                lala++;
        }
        if(lala==0)//欧拉回路
        {
            flag=1;
        }
        else if(lala==2)//欧拉通路
        {
            flag=2;
        }
        else
        {
            flag=0;
        }
        //cout<<flag<<"flag"<<endl;
        if(flag==0)
        {
            puts("Impossible");
            continue;
        }
       int ans=0;
       if(flag==1)
       {
           for(int i=1;i<=n;i++)//每个点的度/2是走的次数。如果走的次数%2==0的话就相当于没有亦或,否则抑或1次
           {
               if(d[i]/2%2==1)
                ans^=num[i];
           }
           ans^=num[1];//依次枚举起点,因为起点要多走一次
           for(int i=2;i<=n;i++)
           {
               ans=max(ans,ans^num[i]);
           }
       }
       /*
       else if(flag==2)//是通路全部异或一遍*****这样写是错误的!
       {
           for(int i=1;i<=n;i++)
           {
               //if(d[i]!=1&&d[i]%2==1)
               if(d[i]/2%2==1)
                ans^=num[i];
           }
       }
       */
       else if(flag==2)//欧拉通路
       {
            for(int i=1;i<=n;i++)
            {
                if(d[i]%2==1)//如果是奇数度,那么这点一定走
                {
                    //cout<<"i: "<<i<<"&&&&&&&&"<<endl;
                    ans^=num[i];
                    d[i]--;
                }
                if((d[i]/2)%2==1)//如果奇数度减一后
                    ans^=num[i];
            }
        }
       printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值