1050. String Subtraction (20)【字符串处理】——PAT (Advanced Level) Practise

题目信息

1050. String Subtraction (20)

时间限制10 ms
内存限制65536 kB
代码长度限制16000 B

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 10^4. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.

解题思路

排除s2中字符输出即可

AC代码

#include <cstdio>
#include <cstring>
char s[10005], aim[10005];

int main()
{
    gets(s);
    gets(aim);
    int len = strlen(s);
    for (int i = 0; i < len; ++i){
        if (NULL == strchr(aim, s[i])){
            putchar(s[i]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值