1059. Prime Factors (25)【素数】——PAT (Advanced Level) Practise

题目信息

1059. Prime Factors (25)

时间限制50 ms
内存限制65536 kB
代码长度限制16000 B

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

解题思路

枚举所有素数

AC代码

#include <cstdio>
#include <cmath>
#include <climits>
using namespace std;
bool prime(long long n){
    long long t = sqrt(n);
    for (long long i = 2; i <= t; ++i){
        if (n%i == 0) return false;
    }
    return true;
}
int main(){
    long long a;
    scanf("%lld", &a);
    printf("%lld=", a);
    if (a == 1){
        printf("1\n");
    }else{
        for (long long i = 2; i <= a; ++i){
            if (prime(i)){
                int k = 0;
                while (a%i == 0){
                    ++k;
                    a /= i;
                }
                if (k == 1){
                    printf("%lld", i);
                }else if (k > 1){
                    printf("%lld^%d", i, k);
                }
                if (k >= 1 && a > 1){
                    printf("*");
                }else if (a == 1){
                    break;
                }
            }
        }
    }
    return 0;
}   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值