1081. Rational Sum (20)【模拟】——PAT (Advanced Level) Practise

题目信息

1081. Rational Sum (20)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24

解题思路

模拟加法,注意结果中分母负号和分子为0情况

AC代码

#include <cstdio>
struct node{
    long long a, b;
    node(long long a, long long b):a(a), b(b){}
};
long long gcd(long long a, long long b){
    return b ? gcd(b, a%b) : a;
}
node add(node& a, node& b){
    node r(a.a*b.b + a.b*b.a, a.b*b.b);
    long long t = gcd(r.a, r.b);
    r.a /= t;
    r.b /= t;
    return r;
}
int main()
{
    int n;
    long long a, b;
    scanf("%d", &n);
    scanf("%lld/%lld", &a, &b); 
    node p(a, b);
    for (int i = 1; i < n; ++i){
        scanf("%lld/%lld", &a, &b);
        node t(a, b);
        p = add(p, t);
    }
    if (p.b < 0){
        p.b *= -1;
        p.a *= -1;
    }
    if (p.a >= p.b){
        printf("%lld", p.a/p.b);
        if (p.a % p.b){
            printf(" %lld/%lld", p.a%p.b, p.b);
        }
    }else{
        if (p.a == 0){
            printf("0");
        }else{
            printf("%lld/%lld", p.a, p.b);
        }
    }
    printf("\n");
    return 0;
}
(Rational Numbers) Create a class called Rational for performing arithmetic with fractions. Write a program to test your class. Use integer variables to represent the private instance variables of the class the numerator and the denominator. Provide a constructor that enables an object of this class to be initialized when it is declared. The constructor should store the fraction in reduced form. The fraction 2/4 is equivalent to 1/2 and would be stored in the object as 1 in the numerator and 2 in the denominator. Provide a no-argument constructor with default values in case no initializers are provided. Provide public methods that perform each of the following operations: a. Add two Rational numbers: The result of the addition should be stored in reduced form. b. Subtract two Rational numbers: The result of the subtraction should be stored in reduced form. c. Multiply two Rational numbers: The result of the multiplication should be stored in reduced form. d. Divide two Rational numbers: The result of the division should be stored in reduced form. e. Print Rational numbers in the form a/b, where a is the numerator and b is the denominator. f. Print Rational numbers in floating-point format. (Consider providing formatting capabilities that enable the user of the class to specify the number of digits of precision to the right of the decimal point.) – 提示: – 有理数是有分子、分母以形式a/b表示的数,其中a是分子,b是分母。例如,1/3,3/4,10/4。 – 有理数的分母不能为0,分子却可以为0。每个整数a等价于有理数a/1。有理数用于分数的精确计算中。例如1/3=0.0000…,它不能使用数据类型double或float的浮点格式精确表示出来,为了得到准确结果,必须使用有理数。 – Java提供了整数和浮点数的数据类型,但是没有提供有理数的类型。 – 由于有理数与整数、浮点数有许多共同特征,并且Number类是数字包装的根类,因此,把有理数类Rational定义为Number类的一个子类是比较合适的。由于有理数是可比较的,那么Rational类也应该实现Comparable接口。+下页图中描述Rational类已将其与Number类和Comparable接口的关系。 –
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值