PAT 1005

  • 题目:
    Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
    Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).
Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:

12345

Sample Output:

one five

  • 解题思路
    1.将输入的整数存储入字符串中
    2.将每一个字符减去0的ASCLL值,转化为每一个整数的值,在将所有整数相加,存储进sum。
    3.将sum的每一位存储进整数数组A
    4.输出数组A对应的英语值

代码实现:

#include <iostream>
#include <string>
using namespace std;
char num[10][10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
int main()
{
    string nums;
    cin >> nums;
    int n = nums.length();
    int sum = 0;
    for(int i = 0; i < n; i++)
        sum += nums[i] -'0';
    int k = 0;
    int A[100];
   // cout <<sum << endl;
    do{
        A[k++] = sum % 10;
        sum = sum /10;
    }while(sum != 0);
    for(int i = k-1; i >0; i--){
        cout<< num[A[i]] << " ";
    }
    cout<< num[A[0]];
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值