PAT A1067

  • 题目:
    Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.
Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

  • 题目大意
    给定0~N-1的一个序列,要求通过两两交换的方式将其变为递增序列,但是规定每次只能用0与其他数字交换。求最小交换次数

  • 分析
    每一用0与0所处位置的数交换,直到序列递增位置。若0在0号位置,会陷入死循环,这时将0与第一个不再他应该在的位置的数交换

代码实现:

#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int A[100010], n, record = 0, res = 0;
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &A[i]);
    }
    for(int i = 0; i < n; i++){             //计算除0之外不在原位置的数
        if(A[i] != i && A[i] != 0)
            record++;
    }
    while(record > 0){
        if(A[0] == 0){                  //若A[0] = 0,找到第一个不在自己位置上的数,交换之
            for(int i = 1; i < n; i++){
                if(A[i] != i){
                    swap(A[0], A[i]);
                    res++;
                    break;
                }
            }
        }
        int i = 1;
        for(i; i < n; i++){                  //找到0的位置
            if(A[i] == 0)
                break;
        }
        int j = 0;
        for(j; j < n; j++){                    //找到0所在下标的位置
            if(A[j] == i)
                break;
        }
        swap(A[i], A[j]);
        res++;
        record--;
    }
    printf("%d", res);
    return 0;
}

此种方法会在测试点2,3会超时。

  • 改进:将数组存储数组每个元素所在的下标,数组下标为序列的值。
    好处在于:清楚的直到所交换的值,交换只用交换值的下标即可。
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int A[100010], n, num, record = 0, res = 0;
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &num);
        A[num] = i;               //数组下标为序列值,数组内的值为序列的下标
        if(num != i && num != 0)       //计算除了0以外不在原位置的数的个数
            record++;
    }
    int k = 1;
    while(record > 0){
        if(A[0] == 0){
            while(k < n){
                if(A[k] != k){
                    swap(A[0], A[k]);
                    res++;
                    break;
                }
                k++;
            }
        }
        while(A[0] != 0){
            swap(A[0],A[A[0]]);
            res++;
            record--;
        }
    }
    printf("%d", res);
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值