PAT A1025

  • 题目:
    Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
    Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

  • 解题思路
    将学号,分数,本地排名,考场号都包括在一个结构体中
    然后借助sort函数进行排序

代码实现:

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
struct student{
    string id;               //准考证号
    int local_rank;              //考场内排名
    int local_num;              //考场号
    int score;                  //分数
} stu[30010];
bool cmp(student a, student b){
    if(a.score != b.score)
        return a.score > b.score;
    else
        return a.id  < b.id;
}
int main()
{
    int n, num, sum = 0;         //n为考场数, num 为每个考场的人数
    cin >> n;
    for(int i = 1; i <= n; i++){
        cin >> num;                 //考场的人数
        for(int j = 0; j < num; j ++){
            cin >> stu[sum].id >> stu[sum].score;
            stu[sum].local_num = i;        //更新考场号
            sum++;
        }
        sort(stu+ sum-num, stu+sum, cmp);        //将该考场人数排序
        //int k = 0;
        stu[sum - num].local_rank = 1;
        for(int i = 1; i < num; i++){
            if(stu[sum-num+i].score == stu[sum -num+i-1].score)
                stu[sum - num + i].local_rank = stu[sum-num+i-1].local_rank;
            else
                stu[sum - num + i].local_rank = i+1;
        }
    }
    cout << sum << endl;
    sort(stu, stu+sum, cmp);
    int r = 1;
    for(int i = 0; i < sum; i++){
        if(i > 0 && stu[i].score != stu[i-1].score)
             r = i+1;
        cout << stu[i].id <<" "<<r <<" " <<stu[i].local_num << " "<<stu[i].local_rank << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值