PAT A1028

5 篇文章 0 订阅
  • 题目:
    Excel can sort records according to any column. Now you are supposed to imitate this function.
    Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).
Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.
Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

  • 解题思路
    利用sort 函数来对结构体进行排序,之后再输出,只用写出3个cmp函数即可。
    1.若c =1, 按照ID从小到大的顺序输出
    2.若c = 2,若姓名相等时,按照ID从小到大的顺序输出,若姓名不相等时,按照姓名从小到大顺序输出
    3.若c = 3,成绩不相等,按照成绩从小到大输出,若成绩相等,按照ID从小到大输出
bool cmp1(Student a, Student b){
    return strcmp(a.ID, b.ID) < 0;
}
bool cmp2(Student a, Student b){
    int s = strcmp(a.name, b.name);
    if(s != 0)
        return s < 0;
    else
        return strcmp(a.ID, b.ID) < 0;
}
bool cmp3(Student a, Student b){
    if(a.grade != b.grade)
        return a.grade < b.grade;
    else
        return strcmp(a.ID, b.ID) < 0;
}

注意事项:
1.需要用scanf来进行输入,printf来控制输出,否则会产生运行超时
2.name 不相等,不能用a.name != b.name 来判断,因为为char类型数组,不是string 类型

此题代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Student{
    char ID[9];
    char name[10];
    int grade;
}stu[100010];
bool cmp1(Student a, Student b){
    return strcmp(a.ID, b.ID) < 0;
}
bool cmp2(Student a, Student b){
    int s = strcmp(a.name, b.name);
    if(s != 0)
        return s < 0;
    else
        return strcmp(a.ID, b.ID) < 0;
}
bool cmp3(Student a, Student b){
    if(a.grade != b.grade)
        return a.grade < b.grade;
    else
        return strcmp(a.ID, b.ID) < 0;
}
int main()
{
    int m, n;
    cin >> m >> n;
    for(int i = 0; i < m; i++){
        scanf("%s%s%d", stu[i].ID, stu[i].name, &stu[i].grade);
    }
    if(n == 1){
        sort(stu, stu+m, cmp1);
    }
    else if( n == 2){
        sort(stu, stu+m, cmp2);
    }
    else
        sort(stu, stu+m, cmp3);
    for(int i = 0; i < m; i++){
        printf("%s %s %d\n",stu[i].ID, stu[i].name, stu[i].grade);
    }
    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值