PAT A1101

  • 题目:
    There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.
Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

  • 题目大意
    输入一个序列,包含N个整数,如果一个数左边的数都比他小,右边的数都比他大,那么称这样的数为主元。求序列中主元的个数,并将主元从小到大输出

  • 分析
    Max_num记录每个数左边序列的最大值,Min[i],记录第i个数右边的最小值
    对于每个元素,若满足: A[i] > Max_num && A[i] < Min[i]
    则将A[i]加入结果容器res,并将主元的个数加1.

代码实现:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
using namespace std;
const int INF = 999999999;
int main()
{
    int n, count1 = 0, Max_num = -1;          //第一个数左边的值为最小值-1
    cin >> n;
    vector<int> A(n), Min(n), res;
    for(int i = 0; i < n; i++)
        scanf("%d", &A[i]);
    int temp = A[n-1];
    Min[n-1] = INF;                 //将最后一个值右边的数设置为最大值
    for(int i = n-2; i >= 0; i--){
        Min[i] = min(A[i+1], Min[i+1]);
    }
    for(int i = 0; i < n; i++){
        if(A[i] > Max_num && A[i] < Min[i]){
            count1++;
            res.push_back(A[i]);
            Max_num = A[i];
        } else {
           Max_num = max(Max_num, A[i]);
        }
    }
    sort(res.begin(), res.end());
    cout << count1 <<'\n';
    if(count1 == 0)
        printf("\n");
    else {
        printf("%d", res[0]);
        for(int i = 1; i < count1; i++)
            printf(" %d", res[i]);
    }
    return  0;
}


方法二:
参考:https://www.liuchuo.net/archives/1917
分析:
对原序列sort排序,逐个比较,当当前元素没有变化并且它左边的所有值的最大值都比它小的时候就可以认为它一定是主元(很容易证明正确性的,毕竟无论如何当前这个数要满足左边都比他大右边都比他小,那它的排名【当前数在序列中处在第几个】一定不会变)~

代码实现:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
using namespace std;
const int INF = 999999999;
int main()
{
    int n, count1 = 0, Max_num = -1;          //第一个数左边的值为最小值-1
    cin >> n;
    vector<int> A(n), B(n), res(n);
    for(int i = 0; i < n; i++){
        scanf("%d", &A[i]);
        B[i] = A[i];
    }
    sort(A.begin(), A.end());
    for(int i = 0; i < n; i++){
        if(A[i] == B[i] && B[i] > Max_num){
            res[count1++] = B[i];
        } else{
            Max_num = max(Max_num, B[i]);
        }
    }
    cout << count1 <<'\n';
    for(int i = 0; i < count1; i++){
        if(i != 0) printf(" ");
        printf("%d", res[i]);
    }
    printf("\n");
    return  0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值