PAT A1024

  • 题目:
    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.
Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

  • 题目大意
    给定一个正整数,求多少不之后,这个正整数和它扭转之后的正整数为回文数

  • 分析
    只用实现数组加法,判断一个数组中存储的数是否为回文数即可。
    特别注意:如输入的为回文数,则不用判断,直接输出这个数以及step = 0 即可。

  • 代码实现:

#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
vector<int> add(vector<int> A){          //数组加法
    vector<int> temp = A;
    reverse(temp.begin(), temp.end());
    int tag = 0, len = A.size();
    for(int i = 0; i < len; i++){
        A[i] = A[i] + temp[i] + tag;
        tag = 0;
        if(A[i] >= 10){
            tag = 1;
            A[i] %= 10;
        }
    }
    if(tag == 1){
        A.resize(len+1);
        A[len] = 1;
    }
    reverse(A.begin(), A.end());
    return A;
}
bool isPali(vector<int> A){              //判断是否位回文序列
    int len = A.size();
    bool tag = true;
    for(int i = 0; i < len/2; i++){
        if(A[i] != A[len - i -1]){
            tag = false;
            break;
        }
    }
    return tag;
}
int main()
{
    string a;
    int k, sum = 0;
    cin >> a >> k;
    vector<int> A;
    int len = a.size();
    for(int i = 0; i < len; i++){
        A.push_back(a[i] - '0');
    }
    if(isPali(A)){               //若输入为回文串,直接输出,并将加的次数置为0
        for(auto a: A)
            cout << a;
        cout << endl << 0;
        return 0;
    }
    bool tag = false;
    while(k--){
        A = add(A);
        sum++;
        if(isPali(A)){
            tag = true;
            break;
        }
    }
    for(int i = 0; i < A.size(); i++)
        cout<< A[i];
    cout <<endl;
    cout << sum;
    return 0;
}

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
string s;
void add(string t){
    int len = s.length(), carry = 0;
    for(int i = 0; i < len; i++){
        s[i] = t[i] + s[i] + carry - '0';
        carry = 0;
        if(s[i] > '9'){
            carry = 1;
            s[i] = s[i] - 10;
        }
    }
    if(carry == 1) s +='1';
    reverse(s.begin(), s.end());
}
int main()
{
    int cnt, i;
    cin >>s >> cnt;
    for( i = 0; i <= cnt; i++){
        string t = s;
        reverse(t.begin(), t.end());
        if(t == s || i == cnt) break;
        add(t);
    }
    cout << s << endl << i;
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值