ACboy needs your help

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?


Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.


Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.


Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0


Sample Output
3
4

6

#include<stdio.h>
#include<string.h>
inline int Max(int a,int b)
{
	return a>b?a:b;
}
int a[110][110],dp[110][110];
int n,m;
int main()
{
	//freopen("b.txt","r",stdin);
	int i,j,k;
	while(scanf("%d %d",&n,&m)==2)
	{
		if(n==0&&m==0) break;
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%d",&a[i][j]);
			memset(dp,0,sizeof(dp));
			for(i=1;i<=n;i++)
			{
				for(j=0;j<=m;j++)
				{
					for(k=m;k>=j;k--)
						dp[i][k]=Max(dp[i][k],dp[i-1][k-j]+a[i][j]);
				}
			}
			printf("%d\n",dp[n][m]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值