ACM刷题之HDU————N!Again

N!Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1152 Accepted Submission(s): 644
 
Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 
Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 
Output
For each case, output N! mod 2009
 
Sample Input
4 
5
 
Sample Output
24
120
 

看着吓人,其实纸老虎
下面是ac代码
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
int main()
{
	__int64 a=1,i,j,y=0,flags=1,shi,ge,len;
	int b[10000];
	char x[10000];
	char c,t;
	while(scanf("%s",x)!=EOF)
	{
		a=1;
		len=strlen(x);
		if(len>2)
			printf("0\n");
	else
	{	
		if(len==2)
		{
			ge=x[1]-'0';
		shi=x[0]-'0';
		shi=shi*10;
		i=shi+ge;
		}
		else
		i=x[0]-'0';
		for(j=1;j<=i;j++)
		{
		a*=j;
		a=a%2009;
		}
		printf("%I64d\n",a); 
	}
	}
} 

41的阶乘%2009 已经等于0了,再增大也还是会等于0.
所以分开判断就好了。。

至于为什么41的阶乘%2009为0,我是怎么发现的,建议可以边阶乘边对2009取余,并输出。你会发现第41个的输出为0,而且之后的都为0。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值