HDU N!


HDU-1042 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34699    Accepted Submission(s): 9717


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

 

Input
One N in one line, process to the end of file.
 

 

Output
For each N, output N! in one line.
 

 

Sample Input
1 2 3
 

 

Sample Output
1 2 6

//解题思路:主要是解决超时问题,我用去对数的方法测了大概需要40000位,但是如何解决这个问题,我没处理好,最后参考别人的思路,真的很好,尤其最后输出的解决方法,真的很赞:参考代码如下:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#define N 8000
int a[N];
int main(){
    int n;
	while(scanf("%d",&n)!=EOF)
	   {   int i,j,k,t;   
	       memset(a,0,sizeof(a));
	       a[0]=1;
		   for(i=2;i<=n;i++) 
		     { for(t=0,j=0;j<N;j++)
		        { k=a[j]*i+t;
				  a[j]=k%100000;
				   t=k/100000; 
		        }
		     } 
    for(i=N-1;!a[i];i--);   
    printf("%d",a[i]);//前面的零不能要 
    while(i)
    printf("%05d",a[--i]);//后面的零要输出 
    printf("\n"); 
	   }
	
	
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值