hdu 2639 Bone Collector II

20 篇文章 0 订阅
Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.


Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).


Sample Input
3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1


Sample Output
12
2

0


第k优解问题。这个题目是01背包的第k优解问题。

思路:

开个二位数组dp[i][j]表示装了体积为i的时候,第j大价值。我们知道背包的动态方程为dp[i]=max(dp[i],dp[i-cost]+val),而我们要求的就从这个方程入手。从网上看到了个比喻,要计算整个年级的前n名,那么只需对每班的前n名进行排序就可以了。同理,我们要开两个数组a[105],b[105]分别记录dp[j][k]与dp[j-cost][k]+val的值,之后按照上述思想往下做就可以了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
int dp[1010][50],a[105],b[105]; 
struct node
{
	int val,cost;
}p[105];
int main()
{
	int t,n,v,k,i,j,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&v,&k);
		for(i=1;i<=n;i++)
		scanf("%d",&p[i].val);
		for(i=1;i<=n;i++)
		scanf("%d",&p[i].cost);
		memset(dp,0,sizeof(dp));
		memset(a,-1,sizeof(a));
		memset(b,-1,sizeof(b));
		for(i=1;i<=n;i++)
		{
			for(j=v;j>=p[i].cost;j--)
			{
				for(m=1;m<=k;m++)
				{
					a[m]=dp[j][m];
					b[m]=dp[j-p[i].cost][m]+p[i].val;
				}
				int x=1,y=1,z=1;
				while(z<=k&&(x<=k||y<=k))
				{
					if(a[x]>b[y])
					{
						dp[j][z]=a[x];
						x++;
					}
					else
					{
						dp[j][z]=b[y];
						y++;
					}
					if(dp[j][z]!=dp[j][z-1])
					z++;
				}
			}
		}
		printf("%d\n",dp[v][k]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值