HDU 6707 Shuffle Card

Problem Description:
 A deck of card consists of n cards. Each card is different, numbered from 1 to n. At first, the cards were ordered from 1 to n. We complete the shuffle process in the following way, In each operation, we will draw a card and put it in the position of the first card, and repeat this operation for m times.

Please output the order of cards after m operations.  
 
Input The first line of input contains two positive integers n and m.(1<=n,m<=105)

The second line of the input file has n Numbers, a sequence of 1 through n.

Next there are m rows, each of which has a positive integer si, representing the card number extracted by the i-th operation. 
Output Please output the order of cards after m operations. (There should be one space after each number.) 
Sample Input:
5 3
1 2 3 4 5
3
4

Sample Output:
3 4 1 2 5

 

题目意思,它给出的牌是让你把那张牌取到队首(**这里不是第几张牌,而是特指那一张**),可用栈来操作,从后往前操作,要是遇到相同的以最后一次操作为主。

代码:

#include <stdio.h>
#include <stack>
#include <string.h>
using namespace std;
stack<int>s;
int main()
{
    int n,m,a[100001],i,k;
    scanf("%d %d",&n,&m);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
    }
    for(i=n;i>=1;i--)
    {
        s.push(a[i]);
    }
    while(m--)
    {
        scanf("%d",&k);
        s.push(k);

    }
    while(!s.empty())
    {
        k=s.top();
        s.pop();
        if(a[k]!=0)
        {
            printf("%d",k);
            a[k]=0;
        }
    }
    return 0;
 } 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值