hdu 1213 How Many Tables

                               How Many Tables

                   Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
                   Total Submission(s): 6984 Accepted Submission(s): 3352


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5

Sample Output
  
  
2 4
 
题意:简单的并查集,如果a和b认识,那么a和b视为一个集合,如果b和c认识则a,b,c视为一个集合,求最后在判断有几个桌子~
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int parent[50005];
int rank[50005];
int flag[50005];
struct Node{
	int parent;
	int rank;
	
}node[50005];
void make_set(int i)// 进行初始化
{
	node[i].parent=i;
	node[i].rank=0;	
}

int get_parent1(int x)     //找到父节点 
{
	if(node[x].parent!=x)
	node[x].parent=get_parent1(node[x].parent);//这个是利用递归找到父节点,并在返回的时候进行压缩路径,朱浩给我叨叨了好久才明白~
	
	return node[x].parent;     //返回父节点
	
}
void Union(int a,int b)    // 将集合进行合并
{
	a=get_parent1(a);    //找到父节点(亲爹啊~)
	b=get_parent1(b);
	if(a==b) return ;
	if(node[a].rank>node[b].rank)  //如果a的父节点的孩子多于b父节点的孩子 则吧b父节点指向a的父节点
	 node[b].parent=a;
	 else
	 {
 		if(node[a].rank==node[b].rank)   //如果深度一样(孩子的个数是一样的)深度加1
 		node[b].rank++;
 		node[a].parent=b;
 	}
}
int main()
{
	int n,m;
	int a,b;
	
	int sum;
	int t=0;
	int cas;
	cin>>cas;
	while(cas--)
	{
		cin>>n>>m;
		memset(flag,0,sizeof(flag));
		for(int i=1;i<=n;i++)
		 make_set(i);
		 
		 for(int i=1;i<=m;i++)
		 {
 			cin>>a>>b;
 			Union(a,b);
 		}
 		sum=0;
 		for(int i=1;i<=n;i++)
 		{
		 	int c=get_parent1(i);
		 	if(!flag[c])
		 	{
	 			sum++;
	 			flag[c]=1;
	 		}
		 }
 		cout<<sum<<endl;
		
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值