Securing the Barn poj

                                                                                                                         Securing the Barn
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1860 Accepted: 1191

Description

Farmer John has installed a new security system on the barn and now must issue a valid password to the cows in the herd. A valid password consists of L (3 <= L <= 15) different lower-case characters (from the traditional latin character set 'a'...'z'), has at least one vowel ('a', 'e', 'i', 'o', or 'u'), at least two consonants (non-vowels), and has characters that appear in alphabetical order (i.e., 'abc' is valid; 'bac' is not).

Given a desired length L along with C lower-case characters, write a program to print all the valid passwords of length L that can be formed from those letters. The passwords must be printed in alphabetical order, one per line.

Input

* Line 1: Two space-separated integers, L and C

* Line 2: C space-separated lower-case characters that are the set of characters from which to build the passwords

Output

* Lines 1..?: Each output line contains a word of length L characters (and no spaces). The output lines must appear in alphabetical order.

Sample Input

4 6
a t c i s w

Sample Output

acis
acit
aciw
acst
acsw
actw
aist
aisw
aitw
astw
cist
cisw
citw
istw

Hint

INPUT DETAILS:
Passwords of length 4 chosen from the given six characters

Source



从六个里选四个字母 需至少1个元音字母,两个辅音字母  然后进行全排列


这道题没什么好解释的~

code:

#include<iostream>
#include<algorithm>
using namespace std;
int num,l,yz,fz,index,len;
char a[27];
int vis[27];

void dfs(int index,int len,int yz,int fz)
{
    if (len==num&&yz>=1&&fz>=2)  
    {
        for (int i=0; i<l; i++)
          if (vis[i])
             cout<<a[i];
                cout<<endl;
        return ;
    }
    for (int i=index; i<l; i++)
    {
                                    
        if (a[i]=='a'||a[i]=='e'||a[i]=='i'||a[i]=='o'||a[i]=='u')
            {
            	 vis[i]=1;
			     dfs(i+1,len+1,yz+1,fz);
			     vis[i]=0;
            }
        else
            {
            	vis[i]=1;
            dfs(i+1,len+1,yz,fz+1);
             vis[i]=0; 
            }                       
    }
}
int main()
{
    cin>>num>>l;
    for (int i=0; i<l; i++)
    {
        cin>>a[i];
        vis[i]=0;
    }
    sort(a,a+l);   
    dfs(0,0,0,0);   
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值