BUY LOW, BUY LOWER poj

                                                                                    BUY LOW, BUY LOWER


Description
The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice:


                    "Buy low; buy lower"




Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.


You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.


Here is a list of stock prices:


 Day   1  2  3  4  5  6  7  8  9 10 11 12


Price 68 69 54 64 68 64 70 67 78 62 98 87






The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is:


Day    2  5  6 10


Price 69 68 64 62


Input
* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given


* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers.


Output
Two integers on a single line:
* The length of the longest sequence of decreasing prices
* The number of sequences that have this length (guaranteed to fit in 31 bits)


In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution.


Sample Input


12
68 69 54 64 68 64 70 67 78 62
98 87


Sample Output


4 2


Source
USACO 2002 February


题解:
首先求出最长的递减子序列的长度,状态转移方程为dp[i]=max(dp[j])+1;(0<=j<i);(下标从0开始)其中dp[i]表示以第i个数结尾的最长递减子序列的长度。这里在最后加一个dp[n]=-1,具体为什么在下一步讲述。


         然后求每一种长度的递减子序列共有几个。状态转移方程:count[i]=sum(coun[j]);(其中a[i]<a[j]&&dp[j]+1==dp[i]);count[i]是以a[i]结尾的以dp[i]长度的递减子序列的个数。这里要注意排除子序列相同的情况!这里给出一个例子加以说明:


                                i  0  1  2  3  4  5   6


                             a[i]  5  8  4  4  3  2  -1


                            dp[i]  1  1  2  2  3  4   5


                        count[i]   1  1  2  2  2  2   2 
      

code:

#include<iostream>
using namespace std;

#define MAX 5050

int f[MAX]; //f[i]表示以第i个元素作为最后一个字符的最长递减子序列的长度
int data[MAX];
int countn[MAX];//表示以第i个元素作为最后一个字符且长度为f[i]的是不同的最长递减子序列的方案数

int main()
{
    int n;
    while (cin>>n && n)
    {
        int i,j;
        int max = 0;

        for (i=1;i<=n;i++)
        {
            cin>>data[i];
            f[i] = 0;
            countn[i] = 0;
        }
        f[0] = 0;

        //求最大递减子序列
        data[0] = 999999999;
        for (i=1;i<=n;i++)
        {
            for (j=i-1;j>=0;j--)
                if (data[j] > data[i] && f[j] + 1 > f[i])
                    f[i] = f[j] + 1;

            if (max < f[i])//将最长的长度保存
                max = f[i];
        }
        //


        //计算数量,也是一个DP,转换方程为
        //countn[i] = all(countn[j])  && dp[i] = dp[j]+1 && data[i]<data[j]
        //还要注意去除掉序列中相同位置且数据相同的元素,我采用的是去除的方法
        int Acount = 0;
        countn[0] = 1;

        for (i=1;i<=n;i++)
        {
            for (j=i-1;j>=0;j--)
            {
                if (f[i] == f[j] && data[i] == data[j]) //位置和数据一致,则不重复计算
                    break;
                if (f[i] == f[j]+1 && data[i] < data[j])
                    countn[i]+=countn[j];
            }
            if (f[i] == max  && countn[i]) //达到了最长子序列的长度
                Acount += countn[i];

        }

        cout<<max<<" "<<Acount<<endl;
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值