NEFU要崛起——第3场 A - Watermelon

                                                                                                    A -Watermelon
                                                                            Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
                          Submit Status Practice CodeForces 4A

Description

One hot summer day Pete and his friend Billy decided to buy a watermelon. They chose the biggest and the ripest one, in their opinion. After that the watermelon was weighed, and the scales showedw kilos. They rushed home, dying of thirst, and decided to divide the berry, however they faced a hard problem.

Pete and Billy are great fans of even numbers, that's why they want to divide the watermelon in such a way that each of the two parts weighs even number of kilos, at the same time it is not obligatory that the parts are equal. The boys are extremely tired and want to start their meal as soon as possible, that's why you should help them and find out, if they can divide the watermelon in the way they want. For sure, each of them should get a part of positive weight.

Input

The first (and the only) input line contains integer number w (1 ≤ w ≤ 100) — the weight of the watermelon bought by the boys.

Output

Print YES, if the boys can divide the watermelon into two parts, each of them weighing even number of kilos; andNO in the opposite case.

Sample Input

Input
8
Output
YES

Sample Output

Hint

For example, the boys can divide the watermelon into two parts of 2 and 6 kilos respectively (another variant — two parts of 4 and 4 kilos).

 

 

 

 

 

 

 

题意:两个小孩买西瓜 看看能不能分两半(分成的两半的质量都是偶数)

注意:0和2分成的是0和1 不符合条件

心得:我次奥~

代码:

#include<iostream>
using namespace std;
int main()
{
	int n;
	cin>>n;
	if(n==2||n==0)
	cout<<"NO"<<endl;
	
	else if(n%2==0)
	 cout<<"YES"<<endl;
	 else 
	 cout<<"NO"<<endl;
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值