hdu 2642 Stars 二维树状数组水题

题目:

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 1729    Accepted Submission(s): 733


Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 

Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 

Output
For each query,output the number of bright stars in one line.
 

Sample Input
  
  
5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200
 

Sample Output
  
  
1 0


一开始所有星星都不亮,B操作点亮星星,D操作熄灭星星,Q操作查询矩形范围内点亮的星星个数。

几点需要注意:
重复点亮(熄灭)的星星不能重复更新;查询时两个点的位置关系不确定;坐标值有0,传参时需要加一



代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<ctype.h>    //tower()
#include<set>  
#include<map>  
#include<iomanip>// cout<<setprecision(1)<<fixed<<a;
#include<vector>   
#include<time.h>  
#include<assert.h>  //assert
#include<cmath>	
#include<algorithm>
#include<bitset>
#include<limits.h>
#include<stack>
#include<queue>
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn=1010;

int bit[maxn][maxn];
bool vis[maxn][maxn];
int n,a,c,b,d;
char ch[3];

int lowbit(int x){return x&(-x);}

void update(int x,int y,int val){
    for(int i=x;i<maxn;i+=lowbit(i)){
        for(int j=y;j<maxn;j+=lowbit(j)){
                bit[i][j]+=val;
        }
    }
}

int sum(int x,int y){
    int res=0;
    for(int i=x;i>0;i-=lowbit(i)){
        for(int j=y;j>0;j-=lowbit(j)){
                res+=bit[i][j];
        }
    }
    return res;
}

int main(){//156MS	6560K
    while(scanf("%d",&n)==1){
        memset(bit,0,sizeof(bit));
        memset(vis,0,sizeof(vis));
        while(n--){
            scanf("%s",ch);
            if(ch[0]=='B'){
                scanf("%d%d",&a,&b);
                a++;b++;
                if(vis[a][b]) continue;
                vis[a][b]=1;
				update(a,b,1);
            }else if(ch[0]=='D'){
                scanf("%d%d",&a,&b);
                a++;b++;
                if(vis[a][b]){
					update(a,b,-1);
	                vis[a][b]=0;                	
                }
            }else if(ch[0]=='Q'){
                scanf("%d%d%d%d",&a,&c,&b,&d);
                a++;c++;b++;d++;
                if(a>c) swap(a,c);
                if(b>d) swap(b,d);
                int ans=sum(c,d)+sum(a-1,b-1)-sum(a-1,d)-sum(c,b-1);
                printf("%d\n",ans);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值