HDU 2642 Stars(二维树状数组 模板题)

Stars

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 118 Accepted Submission(s): 56
 
Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 
Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 
Output
For each query,output the number of bright stars in one line.
 
Sample Input
5
B 581 145
B 581 145
Q 0 600 0 200
D 581 145
Q 0 600 0 200
 
Sample Output
1
0
 
没啥好说的。。。注意 范围 0不可取,要都加一。
全局变量默认初始化为0不需要 memset
#include <iostream>
#include <algorithm>
#include <array>
#include <string.h>
#include <cmath>
#include <stdio.h>
using namespace std;
int flag[1005][1005];
int tree[1005][1005];
int low_bit(int x) {
    return x & (-x);
}

void update(int pos_x, int pos_y, int value) {
    for (int i = pos_x ; i <= 1003; i += low_bit(i)) {
        for (int j = pos_y; j <= 1003; j += low_bit(j)) {
            tree[i][j] += value;
        }
    }
}

int sum(int pos_x, int pos_y) {
    int sum = 0;
    for (int i = pos_x; i > 0; i -= low_bit(i)) {
        for (int j = pos_y; j > 0; j -= low_bit(j)) {
            sum += tree[i][j];
        }
    }
    return sum;
}
int main () {
    int n;
    cin >> n;
    while (n--) {
        char ch[2];
        cin >> ch;
        if (ch[0] == 'B') {
            int a, b;
            cin >> a >> b;
            a++, b++;
            if (!flag[a][b]) {
                flag[a][b] = 1;
                update(a, b, 1);
            }
        } else if (ch[0] == 'Q') {
            int x1, x2, y1, y2;
            cin >> x1 >> x2 >> y1 >> y2;
            x1++, x2++, y1++, y2++;
            if (x1 > x2)
                swap(x1, x2);
            if (y1 > y2)
                swap(y1, y2);
            cout << sum(x2, y2) - sum(x1 - 1, y2) - sum(x2, y1 - 1) + sum(x1 - 1, y1 -1) << endl;
        } else {
            int a, b;
            cin >> a >> b;
            a++, b++;
            if (flag[a][b]) {
                flag[a][b] = 0;
                update(a, b, -1);
            }
        }
    }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值