hdu 2642 star(二维树状数组)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2642点击打开链接



Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 1830    Accepted Submission(s): 781


Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 

Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 

Output
For each query,output the number of bright stars in one line.
 

Sample Input
  
  
5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200
 

Sample Output
  
  
1 0

题意:基础的树状数组操作 注意0,0就好 用book判断有没有已经亮了

#include <bits/stdc++.h>
using namespace std;
int tree[1111][1111];
int book[1111][1111];
int lowbit (int x)
{
    return x&-x;
}
int getsum(int x,int y)
{
    int sum=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            sum+=tree[i][j];
    return sum;
}
void add(int x,int y,int num)
{

        for(int i=x;i<=1000;i+=lowbit(i))
            for(int j=y;j<=1000;j+=lowbit(j))
                tree[i][j]+=num;
        book[x][y]+=num;
}
int main()
{
    int n=0;
    cin >> n ;
    memset(tree,0,sizeof(tree));
    while(n--)
    {
        char c;
        cin >> c;
        if(c=='Q')
        {
            int x1,x2,y1,y2;
            cin >> x1 >> x2 >> y1 >> y2;
            if(x1>x2)
                swap(x1,x2);
            if(y1>y2)
                swap(y1,y2);
            cout << getsum(x2+1,y2+1)-getsum(x1,y2+1)-getsum(x2+1,y1)+getsum(x1,y1) << endl;
        }
        else if(c=='B')
        {
            int x,y;
            cin >> x >> y ;
            if(!book[x+1][y+1])
                add(x+1,y+1,1);
        }
        else if(c=='D')
        {
            int x,y;
            cin >> x >> y ;
            if(book[x+1][y+1])
                {
                    add(x+1,y+1,(-1));
                }
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值