Bone Collector

Home

Problem

Status

Contest

Add Contest

Statistic

LOGOUT

xiaolong

UPDATE

..
nuc 大一dp(gaoji)训练

24:00:00

Overview
Problem
Status
Rank
Discuss

A

B

C

D

E

F

C - Bone Collector
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

HDU 2602

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

FAQ | About Virtual Judge | Forum | Discuss | Open Source Project
All Copyright Reserved ©2010-2014 HUST ACM/ICPC TEAM
Anything about the OJ, please ask in the forum, or contact author:Isun, but NEVER contact freefcw@gmail.com, who is irrelevant to this site !!
Server Time: 2016-05-08 20:46:21

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int OneZorePack(int value[],int volume[],int n,int m)
{
    int f[100000]={0};
    for(int i=0;i<n;i++)//开始老是Wa,不知道为什么,但是在网上搜了一下题,然后改了一下i从0开始就对了,不知道为什么?
    {
        for(int j=m;j>=volume[i];j--)
        {
            f[j]=max(f[j-volume[i]]+value[i],f[j]);
        }
    }
    return f[m];
}
int main()
{
    int t;
    cin>>t;
    int n,m;
    int value[1000+5],volume[1000+5];
    while(t--)
    {
        cin>>n>>m;
        for(int i=0;i<n;i++)
            cin>>value[i];
        for(int i=0;i<n;i++)
            cin>>volume[i];
        cout<<OneZorePack(value,volume,n,m)<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值