SHU2011 Granny's Bike(哈密顿回路+回溯法)

Description

Most days Granny rides her bike around town to do errands, visit, have a cup of coffee, and so on. She enjoys riding her bike and wants to avoid passing the same place twice to add to the interest of the ride. So, each day she draws a map of the places to be visited, with lines connecting those near each other, and sees if she can visit them all and return home without passing a place more than once. Some days she finds she can do this and other days she finds she can't. For example, for the map on the left, Granny can visit every place and return home without passing any place twice, but she can't do it for the map on the right.



She turns to you to write a program to help her.

Input

There will be multiple test cases for this problem. Each test case will have input on multiple lines. The first line will contain the integer n (< 10) noting the number of places Granny wants to visit that day. These will be numbered 1 through n and Granny's house will be numbered 0. The next n lines will be a list of those places near each spot. The first line will be a list of places with a direct route from place 1. The second line will be a list of places with a direct route from place 2, and so on. You may assume that if place i has a direct route to place j, then there is a direct route the other direction also. A line containing 0 will follow the last test case.

Output

For each test case, print one line of the form:Case m: Granny can make the circuit.
Or Case m: Granny can not make the circuit as appropriate. Here, m is the number of the test case, starting at 1.

Sample Input

5
0 2 5
0 1 3
2 4
0 3 5
1 4
4
0 2 3 4
1 3
1 2
0 1
0

Sample Output

Case 1: Granny can make the circuit.
Case 2: Granny can not make the circuit.

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int map[25][25];
int vis[25];
int flag;
int step;
int n;
void dfs(int u)
{
    if(u==0&&step==n+1)
    {
        flag=1;
        return;
    }
    if(flag)
        return;
    for(int i=0;i<=n;i++)
    {
        if(!vis[i]&&map[u][i]==1)
        {
            vis[i]=1;
            step++;
            dfs(i);
            step--;
            vis[i]=0;
        }
    }
    return;
}
int main(void)
{
    int i,j,len,t=1;;
    char str[25];
    while(cin>>n&&n!=0)
    {
        memset(map,0,sizeof(map));
        memset(vis,0,sizeof(vis));
        getchar();
        for(i=1;i<=n;i++)
        {
            gets(str);
            len=strlen(str);
            for(j=0;j<len;j++)
            {
                int a=str[j]-'0';
                map[i][a]=map[a][i]=1;
            }
        }
        flag=0;
        dfs(0);
        cout<<"Case "<<t++<<": ";
        if(flag)
            cout<<"Granny can make the circuit."<<endl;
        else
            cout<<"Granny can not make the circuit."<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值