数论--模除

HDU6025 Coprime Sequence【前缀GCD+后缀GCD】


Coprime Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1415    Accepted Submission(s): 690


Problem Description
Do you know what is called ``Coprime Sequence''? That is a sequence consists of  n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
 

Input
The first line of the input contains an integer  T(1T10), denoting the number of test cases.
In each test case, there is an integer  n(3n100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of  n integers  a1,a2,...,an(1ai109), denoting the elements in the sequence.
 

Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
 

Sample Input
 
 
3 3 1 1 1 5 2 2 2 3 2 4 1 2 4 8
 

Sample Output
 
 
1 2 2
 

问题链接 HDU6025 Coprime Sequence

问题简述

  去除数列中的一个数字,使去除后数列中所有数字的gcd尽可能大

问题分析

  这是一个计算GCD的问题。

程序说明

  数组prefixgcd[],对于prefixgcd[i]=g,g为a[0]-a[i]的GCD,称为前缀GCD。

  数组suffixgcd[],对于suffixgcd[i]=g,g为a[i]-a[n-1]的GCD,称为后缀GCD。

  有了这两个GCD值的数组,那么去掉a[i]的GCD为gcd(prefixgcd[i - 1], suffixgcd[i + 1]),从中找出最大值即可。


C++语言程序如下:



/* HDU6025 Coprime Sequence */  
  
#include <iostream>  
  
using namespace std;  
  
const int N = 100000;  
int a[N], prefixgcd[N], suffixgcd[N];  
  
inline int gcd(int a, int b) {  //inline(修饰词,告诉编译器怎样去编译这段程序,c++特有)
    return b == 0 ? a : gcd(b, a % b);  
}  //辗转相除法(还有递归)
  
int main()  
{  
    int t, n;  
  
    cin >> t;  
    while(t--) {  
        cin >> n;  //输入流输入数据
  
        for(int i=0; i<n; i++)  
            cin >> a[i];  //把数放入数组之中
  
        // 计算前缀GCD  
        prefixgcd[0] = a[0];  
        for(int i=1; i<n; i++)  
            prefixgcd[i] = gcd(prefixgcd[i - 1], a[i]);  
  
        // 计算后缀GCD  
        suffixgcd[n - 1] = a[n - 1];  
        for(int i=n-2; i>=0; i--)   
            suffixgcd[i] = gcd(a[i], suffixgcd[i + 1]);  //从前面算一次gcd,再从后面算一次gcd
 
        int ans = max(suffixgcd[1], prefixgcd[n - 2]); //去掉两头的 
        for(int i=1; i<n - 1; i++)  //从第二个数开始。一个一个地试
            ans = max(ans, gcd(prefixgcd[i - 1], suffixgcd[i + 1]));  
  
        cout << ans << endl;  
    }  
    return 0;  
}  
//先把头和尾的数去掉,算gcd,再从第二个开始算起,(用指针)依次去掉第二个、第三个。。。。算出来。暴力法

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值