数据结构实验之二叉树五:层序遍历

数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

输入

  输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是 一个长度小于50个字符的字符串。

输出

  输出二叉树的层次遍历序列。

示例输入

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

abcdefg
xnuli
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
typedef struct node
{
    char data;
    struct node *rchild,*lchild;
}node,*tree;
char c[1000];
int i;
int xiancreat(tree &t);
void levelorder(tree t);
int main()
{
    int a;
    tree t;
    cin>>a;
    while(a--)
    {
        i=0;
        cin>>c;
        xiancreat(t);
        levelorder(t);
        cout<<endl;
    }
}
int xiancreat(tree &t)
{
    char a;
    a=c[i++];
    if(a==',')
        t=NULL;
    else
    {
        t=(tree)malloc(sizeof(node));
        if(!t) exit(0);
        t->data=a;
        xiancreat(t->lchild);
        xiancreat(t->rchild);
    }
    return 0;
}
void levelorder(tree t)
{
    tree p=t;
    //if(t!=NULL)
    queue<tree>sq;
    if(p)//注意,如果没有会超时
    sq.push(p);
    while(!sq.empty())
    {
        p=sq.front();
        cout<<p->data;
        sq.pop();
        if(p->lchild!=NULL)
            sq.push(p->lchild);
        if(p->rchild!=NULL)
            sq.push(p->rchild);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值