FZU 2111

J - Min Number
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

39012 09012 19012 2

Sample Output

901210921029
特别的烦人,思路正确,怎么写都错了,这道题该几个小时了,最后没了耐心,心塞塞的

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int N = 1005;
char str[N];
int main()
{
int T;
int n;
scanf("%d",&T);
while(T--)
{
scanf("%s%d",str,&n);
int len = strlen(str);
int index ,cnt = 0;
for(int i = 0; i < len; i++)
{
if(cnt >= n)
{
break;
}
int min = INF;
for(int j = len - 1; j >= i; j--)
{
if(min > str[j] && (str[j] != '0' || i ))//str[j] != '0' || i 这个用来控制i为零时其值不能为零,挺简单的然而我没有想到
{
min = str[j];
index = j;
}
}
if (str[i] - str[index] > 0)
{
swap(str[i],str[index]);
cnt++;
}
}
printf("%s\n",str);
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值