Problem Description
As a cute girl, Kotori likes playing Hide and Seek'' with cats particularly.
Hide and Seek” together.
Under the influence of Kotori, many girls and cats are playing
Koroti shots a photo. The size of this photo is n×m, each pixel of the photo is a character of the lowercase(from a' to
z’).
Kotori wants to know how many girls and how many cats are there in the photo.
We define a girl as – we choose a point as the start, passing by 4 different connected points continuously, and the four characters are exactly girl'' in the order.
cat” in the order.
We define two girls are different if there is at least a point of the two girls are different.
We define a cat as -- we choose a point as the start, passing by 3 different connected points continuously, and the three characters are exactly
We define two cats are different if there is at least a point of the two cats are different.
Two points are regarded to be connected if and only if they share a common edge.
Input
The first line is an integer T which represents the case number.
As for each case, the first line are two integers n and m, which are the height and the width of the photo.
Then there are n lines followed, and there are m characters of each line, which are the the details of the photo.
It is guaranteed that:
T is about 50.
1≤n≤1000.
1≤m≤1000.
∑(n×m)≤2×106.
Output
As for each case, you need to output a single line.
There should be 2 integers in the line with a blank between them representing the number of girls and cats respectively.
Please make sure that there is no extra blank.
Sample Input
3
1 4
girl
2 3
oto
cat
3 4
girl
hrlt
hlca
Sample Output
1 0
0 2
4 1
Source
“巴卡斯杯” 中国大学生程序设计竞赛 - 女生专场
让求连在一起的cat的数量,和girl的数量
代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
char mp[1010][1010];
int dis[4][2]= {{1,0},{0,1},{-1,0},{0,-1}};
char g[]= {"girl"}, c[]= {"cat"};
int sum1,sum2,n,m;
void dfs1(int x,int y,int num)
{
if(num==3)
{
sum1++;
return;
}
for(int i=0; i<4; i++)
{
int xx=x+dis[i][0];
int yy=y+dis[i][1];
if(xx>=0&&xx<n&&yy>=0&&yy<m)
{
if(mp[xx][yy]==g[num+1])
dfs1(xx,yy,num+1);
}
}
}
void dfs2(int x,int y,int num)
{
if(num==2)
{
sum2++;
return;
}
for(int i=0; i<4; i++)
{
int xx=x+dis[i][0];
int yy=y+dis[i][1];
if(xx>=0&&xx<n&&yy>=0&&yy<m)
{
if(mp[xx][yy]==c[num+1])
dfs2(xx,yy,num+1);
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
sum1=0, sum2=0;
for(int i=0; i<n; i++) scanf("%s",mp[i]);
for(int i=0; i<n; i++)
{
for(int j=0; j<m; j++)
{
if(mp[i][j]=='g')
{
dfs1(i,j,0);
}
}
}
for(int i=0; i<n; i++)
{
for(int j=0; j<m; j++)
{
if(mp[i][j]=='c')
dfs2(i,j,0);
}
}
printf("%d %d\n",sum1,sum2);
}
return 0;
}