poj 3258 River Hopscotch (最小值最大化 二分+贪心)

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks,N (0 ≤N ≤ 50,000) more rocks appear, each at an integral distanceDi from the start (0 <Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toMrocks (0 ≤MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofM rocks.

     Input
Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
    Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
    Sample Input
25 5 2
2
14
11
21
17
      Sample Output
4
        Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题目意思是:在一条长为L的河流上,其中有n个岩石,问去掉M个岩石使剩下的相邻的岩石最短距离的最大值。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;
typedef long long ll;
int L,n,m;
int a[50010];
int judge(int mid)
{
    int num=n-m;
    int last=0;
    for(int i=0;i<num;i++)
    {
        int cur=last+1;
        while(cur<=n&&a[cur]-a[last]<mid)
            cur++;
        if(cur>n) return 0;
        last=cur;
    }
    return 1;
}
int main()
{
    while(~scanf("%d%d%d",&L,&n,&m))
    {
        if(m==n)
        {
            printf("%d\n",L); continue;
        }
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        a[0]=0;
        a[n+1]=L;  sort(a+1,a+n+1);
        int low=0,high=L;
        while(high-low>1)
        {
            int mid=(low+high)>>1;
            if(judge(mid)) low=mid;
            else high=mid;
        }
        printf("%d\n",low);
    }
    return 0;
}



#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define w(a) while(a)
#define ll long long
int a[50005];
int main()
{
    int l,n,m,i,j,k,minn,maxn,mid,sum,cnt;
    w(~scanf("%d%d%d",&l,&n,&m))
    {
        minn=1000000005;
        maxn=l;
        a[0]=0,a[n+1]=l;
        up(i,1,n)
        scanf("%d",&a[i]);
        n++;
        sort(a,a+n);
        up(i,1,n)
        minn=min(minn,a[i]-a[i-1]);
        w(minn<=maxn)
        {
            mid=(maxn+minn)>>1;
            cnt=sum=0;
            up(i,1,n)
            {
                if((sum+=a[i]-a[i-1])<=mid)
                    cnt++;
                else//连续的几个石头距离和大于mid的话,再把连续距离清0重新枚举
                    sum=0;
            }
            if(cnt<=m)
                minn=mid+1;
            else
                maxn=mid-1;
        }
        printf("%d\n",minn);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值