并查集


https://cn.vjudge.net/contest/157779#problem/B

Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.
Input
There are multiple test cases.
For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.
Proceed to the end of file.
Output
For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.
Sample Input
5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7
Sample Output
You are my elder
You are my brother

找到根的次数越少,说明距里根越近,辈分越高

代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iostream>
int a,b,n;
int father[2005];
void intl()
{
    for(int i=1;i<=n;i++)
        father[i]=i;
}
int find(int x)
{
    if(x!=father[x])
        x=father[x];
    return x;
}
int main()
{

    while(~scanf("%d",&n))
    {
        int sum=0;
        int ans=0;
        memset(father,0,sizeof(father));
        intl();
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            father[a]=b;
        }
        int k1=1;
        while(father[k1]!=k1)
        {
            sum++;
            k1=father[k1];
        }
         int k2=2;
        while(father[k2]!=k2)
        {
            ans++;
            k2=father[k2];
        }
        if(sum<ans)
            printf("You are my younger\n");
        if(sum>ans)
            printf("You are my elder\n");
        if(sum==ans)
            printf("You are my brother\n");
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值