A Bug's Life(种类并查集)

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint
Huge input,scanf is recommended.
异性可组队,找出错误的配对。种类并查集,与根距离为奇数为异性,偶数为同性,rank[]记录与根的距离。结果换成奇偶

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int t,n,a,b,k;
int rank[2005];
int father[2005];
bool flag;
void intl()
{
    flag=false;
    for(int i=1;i<n;i++)
    {
        father[i]=i;
        rank[i]=0;//初始根为自己,距离为0;
    }
}
**int find(int x)//找根并更新距离
{
    if(x==father[x])
        return x;
    else
    {
        int root=find(father[x]);
        rank[x]=(rank[x]+rank[father[x]])&1;
        father[x]=root;
        return father[x];
    }
}**
void combine(int x,int y)
{
    int nx=find(x);
    int ny=find(y);
    if(nx==ny)
    {
        if(rank[x]==rank[y])
            flag=true;
          //  return;
    }
    if(nx!=ny)
    {
       father[nx]=ny;
       rank[nx]=(rank[x]+rank[y]+1)&1;
   }
}
int main()
{
    scanf("%d",&t);
    int r=1;
    while(t--)
    { 
        memset(father,0,sizeof(father));
        memset(rank,0,sizeof(rank));
        scanf("%d%d",&n,&k);
        intl();
        for(int i=1;i<=k;i++)
        {
            scanf("%d%d",&a,&b);
            if(flag)
               continue;
            combine(a,b);
        }
        printf("Scenario #%d:\n",r++);
        if(flag)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
            printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值