A Plug for UNIX(EK/dinic)


You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.
Input
The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.
Output
A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.
Sample Input

4
A
B
C
D
5
laptop B
phone C
pager B
clock B
comb X
3
B X
X A
X D

Sample Output

 

 

1

 

 

n个插座,m个电器,3中转换器(数量不限)题上给出插座的类型,每个电器所配对的插座类型,和转换器类型,求最少有几个电器没法充电。用最大流求最多能充电的的电器个数ans,用m-ans即可。加一个0点作为源点和点maxn-1为汇点,0点与电器名称相连,容量为1,电器与自己的配对类型插座相连,容量为1,每个转换器的两个点相连,容量为inf(因为转换器数量不限)给出现的插座类型编号,每个插座与汇点相连容量为1.

EK

 

include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
const int maxn=1010;
int g[maxn][maxn];
int pre[maxn];
int vis[maxn];
int n,m,k;
map<string,int>num;//给结点编号
int bfs()
{
    memset(pre,-1,sizeof(pre));
    memset(vis,0,sizeof(vis));
    queue<int >q;
    while(!q.empty()){q.pop();}
    q.push(0);
    vis[0]=1;
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        for(int i=0;i<maxn;i++)
        {
            if(!vis[i]&&g[now][i])
            {
                vis[i]=1;
                pre[i]=now;
                if(i==maxn-1)
                    return 1;
                q.push(i);
            }
        }
    }
    return 0;
}
int ek()
{
    int v,d,maxflow=0;
    while(bfs())
    {
        v=maxn-1;
        d=inf;
        while(v!=0)
        {
            d=min(d,g[pre[v]][v]);
            v=pre[v];
        }
        maxflow+=d;
        v=maxn-1;
        while(v!=0)
        {
            g[pre[v]][v]-=d;
            g[v][pre[v]]+=d;
            v=pre[v];
        }
    }
    return maxflow;
}
int main()
{
  while(~scanf("%d",&n))
  {
      memset(g,0,sizeof(g));
      num.clear();
      int id=1;
      string ch,cap;
      for(int i=0;i<n;i++)
      {
          cin>>ch;
          num[ch]=id++;//插座、编号
          g[num[ch]][maxn-1]=1;//源点插座之间容量为1
      }
      scanf("%d",&m);
      for(int i=0;i<m;i++)
      {
          cin>>cap>>ch;
          if(num[ch]==0)
          num[ch]=id++;
            num[cap]=id++;
          g[num[cap]][num[ch]]=1;//设备和它的插座之间容量为1
          g[0][num[cap]]=1;//设备到汇点容量为1
      }
      scanf("%d",&k);
      for(int i=0;i<k;i++)
      {
          cin>>ch>>cap;
          if(num[ch]==0)
          num[ch]=id++;
          if(num[cap]==0)
          num[cap]=id++;
          g[num[ch]][num[cap]]=inf;
      }
      printf("%d\n",m-ek());
  }
}


dinic:

 

#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
const int maxn=1010;
int g[maxn][maxn];
int pre[maxn];
int dis[maxn];
int vis[maxn];
int n,m,k;
map<string,int>num;//给结点编号
int bfs()
{
    memset(dis,0,sizeof(dis));
    queue<int >q;
    while(!q.empty()){q.pop();}
    q.push(0);
    dis[0]=1;
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        for(int i=0;i<maxn;i++)
        {
            if(!dis[i]&&g[now][i]>0)
            {
                dis[i]=dis[now]+1;
                q.push(i);
            }
        }
    }
    if(dis[maxn-1]) return 1;
    return 0;
}
int dfs(int s,int u)
{
    if(s==maxn-1) return u;
    int tmp=u;
    for(int i=0;i<maxn&&tmp;i++)
    {
        if(dis[i]==dis[s]+1&&g[s][i])
        {
            int t=dfs(i,min(g[s][i],tmp));
            g[s][i]-=t;
            g[i][s]+=t;
            tmp-=t;
        }
    }
    return u-tmp;
}
int Ans()
{
    int t=0,ans=0;
    while(bfs())
    {
        while(t=dfs(0,inf))
            ans+=t;
    }
    return ans;
}
int main()
{
  while(~scanf("%d",&n))
  {
      memset(g,0,sizeof(g));
      num.clear();
      int id=1;
      string ch,cap;
      for(int i=0;i<n;i++)
      {
          cin>>ch;
          num[ch]=id++;//插座、编号
          g[num[ch]][maxn-1]=1;//源点插座之间容量为1
      }
      scanf("%d",&m);
      for(int i=0;i<m;i++)
      {
          cin>>cap>>ch;
          if(num[ch]==0)
          num[ch]=id++;
            num[cap]=id++;
          g[num[cap]][num[ch]]=1;//设备和它的插座之间容量为1
          g[0][num[cap]]=1;//设备到汇点容量为1
      }
      scanf("%d",&k);
      for(int i=0;i<k;i++)
      {
          cin>>ch>>cap;
          if(num[ch]==0)
          num[ch]=id++;
          if(num[cap]==0)
          num[cap]=id++;
          g[num[ch]][num[cap]]=inf;
      }
      printf("%d\n",m-Ans());
  }
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值